[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAGXu5jJCjsroBwF-darFgNbAn8F_OGgfkf+drvtUbbd6uN2_xg@mail.gmail.com>
Date: Sun, 9 Jul 2017 07:02:47 -0700
From: Kees Cook <keescook@...omium.org>
To: Baoquan He <bhe@...hat.com>
Cc: LKML <linux-kernel@...r.kernel.org>,
"x86@...nel.org" <x86@...nel.org>,
Matt Fleming <matt@...eblueprint.co.uk>,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...nel.org>,
"H. Peter Anvin" <hpa@...or.com>, izumi.taku@...fujitsu.com,
fanc.fnst@...fujitsu.com, Thomas Garnier <thgarnie@...gle.com>
Subject: Re: [PATCH v4 3/4] x86/boot/KASLR: Rename process_e820_entry() into process_mem_region()
On Sun, Jul 9, 2017 at 5:37 AM, Baoquan He <bhe@...hat.com> wrote:
> Now process_e820_entry() is not limited to e820 entry processing, rename
> it to process_mem_region(). And adjust the code comment accordingly.
>
> Signed-off-by: Baoquan He <bhe@...hat.com>
Acked-by: Kees Cook <keescook@...omium.org>
-Kees
> ---
> arch/x86/boot/compressed/kaslr.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/arch/x86/boot/compressed/kaslr.c b/arch/x86/boot/compressed/kaslr.c
> index 36ff9f729c43..99c7194f7ea6 100644
> --- a/arch/x86/boot/compressed/kaslr.c
> +++ b/arch/x86/boot/compressed/kaslr.c
> @@ -479,7 +479,7 @@ static unsigned long slots_fetch_random(void)
> return 0;
> }
>
> -static void process_e820_entry(struct mem_vector *entry,
> +static void process_mem_region(struct mem_vector *entry,
> unsigned long minimum,
> unsigned long image_size)
> {
> @@ -517,7 +517,7 @@ static void process_e820_entry(struct mem_vector *entry,
> /* Potentially raise address to meet alignment needs. */
> region.start = ALIGN(region.start, CONFIG_PHYSICAL_ALIGN);
>
> - /* Did we raise the address above this e820 region? */
> + /* Did we raise the address above the passed in memory entry? */
> if (region.start > cur_entry.start + cur_entry.size)
> return;
>
> @@ -573,7 +573,7 @@ static void process_e820_entries(unsigned long minimum,
> continue;
> region.start = entry->addr;
> region.size = entry->size;
> - process_e820_entry(®ion, minimum, image_size);
> + process_mem_region(®ion, minimum, image_size);
> if (slot_area_index == MAX_SLOT_AREA) {
> debug_putstr("Aborted e820 scan (slot_areas full)!\n");
> break;
> --
> 2.5.5
>
--
Kees Cook
Pixel Security
Powered by blists - more mailing lists