[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170817091705.5np3utcqeia5em4x@gmail.com>
Date: Thu, 17 Aug 2017 11:17:05 +0200
From: Ingo Molnar <mingo@...nel.org>
To: "Kirill A. Shutemov" <kirill.shutemov@...ux.intel.com>
Cc: Linus Torvalds <torvalds@...ux-foundation.org>,
Andrew Morton <akpm@...ux-foundation.org>, x86@...nel.org,
Thomas Gleixner <tglx@...utronix.de>,
Ingo Molnar <mingo@...hat.com>,
"H. Peter Anvin" <hpa@...or.com>, Andi Kleen <ak@...ux.intel.com>,
Dave Hansen <dave.hansen@...el.com>,
Andy Lutomirski <luto@...capital.net>,
Michal Hocko <mhocko@...nel.org>, linux-mm@...ck.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCHv4 11/14] x86/mm: Replace compile-time checks for 5-level
with runtime-time
* Kirill A. Shutemov <kirill.shutemov@...ux.intel.com> wrote:
> --- a/arch/x86/mm/fault.c
> +++ b/arch/x86/mm/fault.c
> @@ -459,7 +459,7 @@ static noinline int vmalloc_fault(unsigned long address)
> if (pgd_none(*pgd)) {
> set_pgd(pgd, *pgd_ref);
> arch_flush_lazy_mmu_mode();
> - } else if (CONFIG_PGTABLE_LEVELS > 4) {
> + } else if (!p4d_folded) {
BTW: the new name is worse I think, not just the cryptic 'p4d' acronym that will
generally be much less well known than '5 level page tables', but also the logic
inversion from common usage patterns that generally want to do something if the
'fifth level is not folded' i.e. if 'the fifth level is enabled'.
How about calling it 'pgtable_l5_enabled'? The switch tells us that the fifth
level of our page tables is enabled. Harmonizes with '5 level paging support'. It
also won't have the logic inversion but can be used directly:
} else if (pgtable_l5_enabled) {
( In theory we could use that nomenclature for PAE as well, 'pgtable_l3_enabled',
or so - although PAE is special in more ways than just one more level, so it
might not be practical. )
Thanks,
Ingo
Powered by blists - more mailing lists