lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 25 Aug 2017 10:06:08 +0900
From:   Chanwoo Choi <cw00.choi@...sung.com>
To:     Greg KH <gregkh@...uxfoundation.org>
Cc:     "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
        "Chanwoo Choi (samsung.com)" <cw00.choi@...sung.com>,
        "Chanwoo Choi (samsung.com)" <chanwoo@...nel.org>,
        함명주 <myungjoo.ham@...sung.com>,
        대인기 <inki.dae@...sung.com>
Subject: [GIT PULL] extcon next for v4.14

Dear Greg,

This is extcon-next pull request for v4.14. I add detailed description of
this pull request on below. Please pull extcon with following updates.

Best Regards,
Chanwoo Choi

The following changes since commit 5771a8c08880cdca3bfb4a3fc6d309d6bba20877:

  Linux v4.13-rc1 (2017-07-15 15:22:10 -0700)

are available in the git repository at:

  git://git.kernel.org/pub/scm/linux/kernel/git/chanwoo/extcon.git tags/extcon-next-for-4.14

for you to fetch changes up to 4243c408f7402e254454d4770dfc1437545eba1b:

  extcon: max77693: Allow MHL attach notifier (2017-08-25 09:32:27 +0900)

----------------------------------------------------------------
Update extcon for 4.14

Detailed description for this pull request:
1. Add new 'extcon-usbc-cros-ec.c' driver
- ChromeOS Embedded Controller extcon driver supports
  the detection of the Display Port (EXTCON_DISP_DP)
  through USB C-type and contol it.

2. Update extcon core
- Modify the description for both functions and structures
  in order to improve the readability and give the more correct
  guide about the role of functions because there are different
  explanation even if the same arguments.

- Keep the indentation with tab instead of space

- Remove the following deprecated extcon API. The deprecated API
  are exchanged on all of linux tree.
  : extcon_get_cable_state_() -> extcon_get_state()
  : extcon_set_cable_state_() -> extcon_set_state_sync()

3. Include the two immutable branch as following:
- ib-extcon-mfd-4.14 for the 'extcon-ubsc-cros-ec.c' driver
  because the patches of 'extcon-ubsc-cros-ec.c' touch the MFD directory.
- ib-extcon-usb-phy-4.14 for removing the deprecated extcon API
  because the usb/phy driver usese the deprecated extcon API.
  So, this immutable branch alters the extcon API and then
  remove them from extcon.

4. Fix minor issue of extcon driver
- Fix the MHL detection on extcon-max77693.c
- Convert to using %pOF instead of full_name on extcon.c
- Add 'const' kerywod for acpi_device_id on extcon-intel-int3496.c

----------------------------------------------------------------
Arvind Yadav (1):
      extcon: int3496: Constify acpi_device_id

Benson Leung (2):
      extcon: cros-ec: Add extcon-cros-ec driver to support display out
      dt-bindings: extcon: Add support for cros-ec device

Chanwoo Choi (10):
      phy: qcom-usb-hs: Replace the extcon API
      Merge remote-tracking branch 'origin/ib-extcon-mfd-4.14' into extcon-next
      phy: rockchip-inno-usb2: Replace the extcon API
      phy: phy-bcm-ns2-usbdrd: Replace the deprecated extcon API
      usb: gadget: udc: Replace the deprecated extcon API
      extcon: Remove deprecated extcon_set/get_cable_state_()
      Merge branch 'ib-extcon-usb-phy-4.14' into extcon-next
      extcon: Remove unused CABLE_NAME_MAX definition
      extcon: Correct description to improve the readability
      extcon: Use tab instead of space for indentation

Christophe JAILLET (1):
      extcon: cros-ec: Fix a potential NULL pointer dereference

Maciej Purski (1):
      extcon: max77693: Allow MHL attach notifier

Rob Herring (1):
      extcon: Convert to using %pOF instead of full_name

 .../bindings/extcon/extcon-usbc-cros-ec.txt        |  24 ++
 drivers/extcon/Kconfig                             |   7 +
 drivers/extcon/Makefile                            |   1 +
 drivers/extcon/devres.c                            |  50 ++-
 drivers/extcon/extcon-intel-int3496.c              |   2 +-
 drivers/extcon/extcon-max77693.c                   |   5 +-
 drivers/extcon/extcon-usbc-cros-ec.c               | 417 +++++++++++++++++++++
 drivers/extcon/extcon.c                            | 279 +++++++-------
 drivers/phy/broadcom/phy-bcm-ns2-usbdrd.c          |   8 +-
 drivers/phy/qualcomm/phy-qcom-usb-hs.c             |  14 +-
 drivers/phy/rockchip/phy-rockchip-inno-usb2.c      |  10 +-
 drivers/usb/gadget/udc/snps_udc_plat.c             |   6 +-
 include/linux/extcon.h                             | 130 +++----
 include/linux/mfd/cros_ec_commands.h               |  75 ++++
 14 files changed, 756 insertions(+), 272 deletions(-)
 create mode 100644 Documentation/devicetree/bindings/extcon/extcon-usbc-cros-ec.txt
 create mode 100644 drivers/extcon/extcon-usbc-cros-ec.c

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ