lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 30 Aug 2017 14:51:16 +0200 (CEST)
From:   Miroslav Benes <mbenes@...e.cz>
To:     Josh Poimboeuf <jpoimboe@...hat.com>
cc:     Petr Mladek <pmladek@...e.com>, jeyu@...nel.org, jikos@...nel.org,
        lpechacek@...e.cz, live-patching@...r.kernel.org,
        linux-kernel@...r.kernel.org, Andy Lutomirski <luto@...nel.org>,
        "H. Peter Anvin" <hpa@...or.com>, Ingo Molnar <mingo@...hat.com>,
        Michael Ellerman <mpe@...erman.id.au>,
        Oleg Nesterov <oleg@...hat.com>,
        Thomas Gleixner <tglx@...utronix.de>
Subject: Re: [PATCH v2 0/3] livepatch: Introduce force sysfs attribute

On Wed, 16 Aug 2017, Josh Poimboeuf wrote:

> On Wed, Aug 16, 2017 at 04:50:07PM +0200, Petr Mladek wrote:
> > On Fri 2017-08-11 16:11:31, Josh Poimboeuf wrote:
> > > On Thu, Aug 10, 2017 at 12:48:12PM +0200, Miroslav Benes wrote:
> > > > Now there is a sysfs attribute called "force", which provides two
> > > > functionalities, "signal" and "force" (previously "unmark"). I haven't
> > > > managed to come up with better names. Proposals are welcome. On the
> > > > other hand I do not mind it much.
> > > 
> > > Now "force" has two meanings, which is a little confusing.  What do you
> > > think about just having two separate write-only sysfs flags?
> > > 
> > >   echo 1 > /sys/kernel/livepatch/signal
> > >   echo 1 > /sys/kernel/livepatch/force
> > 
> > I like the simplicity but I wonder if there might be more actions
> > that need to be forced in the future. Then this might cause
> > confusion.
> > 
> > For example, we have force_module_load attribute in kGraft.
> > It allows to load a module even when it is refused by a livepatch.
> > It is handy when there is a harmless bug in the patch.

We can add force_module_load attribute too in that case. But I see your 
point, I just don't think it would be that serious as far as confusion is 
concerned.

> What if we put the flags in the per-patch dir?
> 
>   /sys/kernel/livepatch/<patch>/signal
>   /sys/kernel/livepatch/<patch>/force
> 
> That seems pretty unambiguous.  The "force" is specific to the patch, it
> clearly means we are forcing the patch.

Petr, would this solve your worries?

Thanks,
Miroslav

Powered by blists - more mailing lists