[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <1504778971-13573-1-git-send-email-luca.abeni@santannapisa.it>
Date: Thu, 7 Sep 2017 12:09:27 +0200
From: luca abeni <luca.abeni@...tannapisa.it>
To: linux-kernel@...r.kernel.org
Cc: Peter Zijlstra <peterz@...radead.org>,
Ingo Molnar <mingo@...hat.com>,
Juri Lelli <juri.lelli@....com>,
Steven Rostedt <rostedt@...dmis.org>,
Daniel Bristot de Oliveira <bristot@...hat.com>,
Mathieu Poirier <mathieu.poirier@...aro.org>,
luca abeni <luca.abeni@...tannapisa.it>
Subject: [PATCH 0/4] SCHED_DEADLINE fixes and cleanups
Hi,
here are some fixes, cleanups and improvements for SCHED_DEADLINE.
Patch 0001 just removes a duplicate declaration from sched/sched.h.
Patch 0002 fixes a bug I introduced some time ago, when removing
the dl_new field from sched_dl_entity in
72f9f3fdc928dc3ecd223e801b32d930b662b6ed.
This is the same patch I already sent some time ago, because at the
end of the discussion it was not clear to me if some changes are needed
or not.
Patch 0003 renames the confusing __dl_clear() function, as suggested
by Peter (actually, this is Peter's patch... I hope I did the SoB thing
correctly)
Patch 0004 saves reduces the size of sched_dl_entity by using bitfields
instead of whole integers for boolean values.
Peter Zijlstra (1):
sched/deadline: rename __dl_clear() to __dl_sub()
luca abeni (3):
sched/sched.h: remove duplicate prototype of __dl_clear_params()
sched/deadline: fix switching to -deadline
sched/deadline: use C bitfields for the state flags
include/linux/sched.h | 8 ++++----
kernel/sched/deadline.c | 21 +++++++++------------
kernel/sched/sched.h | 3 +--
3 files changed, 14 insertions(+), 18 deletions(-)
--
2.7.4
Powered by blists - more mailing lists