[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <alpine.DEB.2.20.1709081045330.3165@hadrien>
Date: Fri, 8 Sep 2017 10:46:21 +0200 (CEST)
From: Julia Lawall <julia.lawall@...6.fr>
To: harsha <harshasharmaiitr@...il.com>
cc: gregkh@...uxfoundation.org, devel@...verdev.osuosl.org,
linux-kernel@...r.kernel.org, outreachy-kernel@...glegroups.com
Subject: Re: [Outreachy kernel] [PATCH] staging: rt8712: xmit_linux: Avoid
multiple assignments in a single line
On Fri, 8 Sep 2017, harsha wrote:
> Fixed coding style issue
>
> Signed-off-by: Harsha Sharma <harshasharmaiitr@...il.com>
> ---
> drivers/staging/rtl8712/xmit_linux.c | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/staging/rtl8712/xmit_linux.c b/drivers/staging/rtl8712/xmit_linux.c
> index d13fd15..03c6b0c 100644
> --- a/drivers/staging/rtl8712/xmit_linux.c
> +++ b/drivers/staging/rtl8712/xmit_linux.c
> @@ -49,8 +49,10 @@ static uint remainder_len(struct pkt_file *pfile)
> void _r8712_open_pktfile(_pkt *pktptr, struct pkt_file *pfile)
> {
> pfile->pkt = pktptr;
> - pfile->cur_addr = pfile->buf_start = pktptr->data;
> - pfile->pkt_len = pfile->buf_len = pktptr->len;
I think this may be considered to be more readable as is.
julia
> + pfile->cur_addr = pktptr->data;
> + pfile->buf_start = pfile->cur_addr;
> + pfile->pkt_len = pktptr->len;
> + pfile->buf_len = pfile->pkt_len;
> pfile->cur_buffer = pfile->buf_start;
> }
>
> --
> 1.9.1
>
> --
> You received this message because you are subscribed to the Google Groups "outreachy-kernel" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to outreachy-kernel+unsubscribe@...glegroups.com.
> To post to this group, send email to outreachy-kernel@...glegroups.com.
> To view this discussion on the web visit https://groups.google.com/d/msgid/outreachy-kernel/1504859870-13153-1-git-send-email-harshasharmaiitr%40gmail.com.
> For more options, visit https://groups.google.com/d/optout.
>
Powered by blists - more mailing lists