lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 18 Sep 2017 16:19:07 +0530
From:   Himanshi Jain <>
To:     Jonathan Cameron <>
Cc:     Lars-Peter Clausen <>,
        Greg KH <>,
        Jonathan Cameron <>,
        driverdev <>,
        Daniel Baluta <>,
        "Hennerich, Michael" <>,,
        Linux Kernel Mailing List <>,
        Nick Desaulniers <>,
        outreachy-kernel <>,
        Peter Meerwald <>,
        Hartmut Knaack <>
Subject: Re: [PATCH v2 1/2] include: linux: sysfs: Add __ATTR_NAMED macro

On Thu, Sep 14, 2017 at 2:20 AM, Jonathan Cameron
<> wrote:
> On 13 September 2017 12:23:31 GMT-07:00, Lars-Peter Clausen <> wrote:
>>On 09/13/2017 08:58 PM, Greg KH wrote:
>>> On Wed, Sep 13, 2017 at 06:03:10PM +0100, Jonathan Cameron wrote:
>>>> On Wed, 13 Sep 2017 14:14:07 +0530
>>>> Himanshi Jain <> wrote:
>>>>> Add __ATTR_NAMED macro similar to __ATTR but taking name as a
>>>>> string instead of implicit conversion of argument to string using
>>>>> the macro _stringify(_name).
>>>>> Signed-off-by: Himanshi Jain <>
>>>>> ---
>>>>>  include/linux/sysfs.h | 7 +++++++
>>>>>  1 file changed, 7 insertions(+)
>>>>> diff --git a/include/linux/sysfs.h b/include/linux/sysfs.h
>>>>> index aa02c32..20321cf 100644
>>>>> --- a/include/linux/sysfs.h
>>>>> +++ b/include/linux/sysfs.h
>>>>> @@ -104,6 +104,13 @@ struct attribute_group {
>>>>>    .store  = _store,                                               \
>>>>>  }
>>>>> +#define __ATTR_NAMED(_name, _mode, _show, _store) {                       \
>>>> I'm not sure about the naming here.  The normal __ATTR macro is also
>>>> 'named'.  Maybe something as awful as
>>>> Greg what do you think?
>>> ick ick ick.
>>>> This is all to allow us to have names with operators in them without
>>>> checkpatch complaining about them... A worthwhile aim just to stop
>>>> more people wasting time trying to 'fix' those cases by adding
>>> Yeah, but this really seems "heavy" for just a crazy sysfs name in a
>>> macro.  Adding a whole new "core" define for that is a hard sell...
>>> I also want to get rid of the "generic" __ATTR type macros, and force
>>> people to use the proper _RW and friends instead.  I don't want to
>>> another new one that people will start to use that I later have to
>>> change...
>>> So no, I don't like this, how about just changing your macros
>>> No one else has this problem :)
>>Nobody else realized they have this problem yet. E.g. there are a few
>>of __ATTR in block/genhd.c that have the same issue and are likely to
>>generate the same false positives from static checkers.
> For IIO there is the option of moving these over to the core generated available callbacks, but
> that won't work in every case and is a more major change.  I need to shift a few more drivers
> over to the available callbacks and see how well it works out.  Might find time to do one in a
>  gap between interesting talks this afternoon...

Can I help you in this? It is about exploring options as far as I can
make out, although can't really understand what options are those for

Or do you want me to put comments to not to fix this checkpatch
warning as you suggested earlier?

> If I am feeling really keen I might write this missing docs I promised a while back on that stuff. Jet lag dependant...
> Jonathan
>>To unsubscribe from this list: send the line "unsubscribe linux-iio" in
>>the body of a message to
>>More majordomo info at
> --
> Sent from my Android device with K-9 Mail. Please excuse my brevity.

Powered by blists - more mailing lists