[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <1505752582.2685.11.camel@wdc.com>
Date: Mon, 18 Sep 2017 16:36:23 +0000
From: Bart Van Assche <Bart.VanAssche@....com>
To: "mingo@...nel.org" <mingo@...nel.org>,
"longman@...hat.com" <longman@...hat.com>,
"rostedt@...dmis.org" <rostedt@...dmis.org>,
"axboe@...nel.dk" <axboe@...nel.dk>
CC: "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"linux-block@...r.kernel.org" <linux-block@...r.kernel.org>
Subject: Re: [PATCH v5] blktrace: Fix potentail deadlock between delete &
sysfs ops
On Sat, 2017-09-16 at 19:37 -0700, Waiman Long wrote:
> diff --git a/include/linux/fs.h b/include/linux/fs.h
> index 339e737..330b572 100644
> --- a/include/linux/fs.h
> +++ b/include/linux/fs.h
> @@ -448,7 +448,7 @@ struct block_device {
>
> /* The counter of freeze processes */
> int bd_fsfreeze_count;
> - /* Mutex for freeze */
> + /* Mutex for freeze and blktrace */
> struct mutex bd_fsfreeze_mutex;
> } __randomize_layout;
This patch changes the meaning of bd_fsfreeze_mutex significantly. Please rename
that mutex such that its name matches its new role.
Thanks,
Bart.
Powered by blists - more mailing lists