[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20170922095432.GA8112@kroah.com>
Date: Fri, 22 Sep 2017 11:54:32 +0200
From: Greg KH <gregkh@...uxfoundation.org>
To: rui_feng@...lsil.com.cn
Cc: lee.jones@...aro.org, arnd@...db.de, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] mfd: rtsx: Add support for RTS5260
On Fri, Sep 22, 2017 at 05:36:24PM +0800, rui_feng@...lsil.com.cn wrote:
> From: rui_feng <rui_feng@...lsil.com.cn>
>
> Add support for new chip rts5260.
> In order to support rts5260,the definitions of some internal
> registers and workflow have to be modified and are different from its
> predecessors. So we need this patch to ensure RTS5260 can work.
>
> Signed-off-by: Rui Feng <rui_feng@...lsil.com.cn>
Nit, this name needs to match your "From:" line. It almost does :)
Why is this a drivers/misc/ driver?
> --- /dev/null
> +++ b/drivers/misc/rts5260.c
> @@ -0,0 +1,590 @@
> +/* Driver for Realtek PCI-Express card reader
> + *
> + * Copyright(c) 2016-2017 Realtek Semiconductor Corp. All rights reserved.
> + *
> + * This program is free software; you can redistribute it and/or modify it
> + * under the terms of the GNU General Public License as published by the
> + * Free Software Foundation; either version 2, or (at your option) any
> + * later version.
Do you really mean "any later version"? (I have to ask...)
> + *
> + * This program is distributed in the hope that it will be useful, but
> + * WITHOUT ANY WARRANTY; without even the implied warranty of
> + * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
> + * General Public License for more details.
> + *
> + * You should have received a copy of the GNU General Public License along
> + * with this program; if not, see <http://www.gnu.org/licenses/>.
> + *
> + * Author:
> + * Steven FENG <steven_feng@...lsil.com.cn>
> + * Rui FENG <rui_feng@...lsil.com.cn>
> + * Wei WANG <wei_wang@...lsil.com.cn>
> + */
> +
> +#include <linux/module.h>
> +#include <linux/delay.h>
> +#include <linux/mfd/rtsx_pci.h>
> +
> +#include "../mfd/rtsx_pcr.h"
That looks "odd" :(
thanks,
greg k-h
Powered by blists - more mailing lists