[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <a8a93630-8b7a-9e4e-0277-8db13d4563e8@suse.cz>
Date: Fri, 29 Sep 2017 14:00:37 +0200
From: Vlastimil Babka <vbabka@...e.cz>
To: Johannes Thumshirn <jthumshirn@...e.de>,
Christoph Lameter <cl@...ux.com>,
Pekka Enberg <penberg@...nel.org>,
David Rientjes <rientjes@...gle.com>,
Joonsoo Kim <iamjoonsoo.kim@....com>,
Andrew Morton <akpm@...ux-foundation.org>
Cc: linux-mm@...ck.org, linux-kernel@...r.kernel.org,
Damien Le Moal <damien.lemoal@....com>,
Christoph Hellwig <hch@....de>
Subject: Re: [PATCH 1/6] mm: add kmalloc_array_node and kcalloc_node
On 09/27/2017 10:20 AM, Johannes Thumshirn wrote:
> We have kmalloc_array() and kcalloc() wrappers on top of kmalloc() which
> ensure us overflow free multiplication for the size of a memory
> allocation but these implementations are not NUMA-aware.
>
> Likewise we have kmalloc_node() which is a NUMA-aware version of
> kmalloc() but the implementation is not aware of any possible overflows in
> eventual size calculations.
>
> Introduce a combination of the two above cases to have a NUMA-node aware
> version of kmalloc_array() and kcalloc().
>
> Signed-off-by: Johannes Thumshirn <jthumshirn@...e.de>
Sounds better than custom open-coded stuff indeed.
Acked-by: Vlastimil Babka <vbabka@...e.cz>
> ---
> include/linux/slab.h | 16 ++++++++++++++++
> 1 file changed, 16 insertions(+)
>
> diff --git a/include/linux/slab.h b/include/linux/slab.h
> index 41473df6dfb0..aaf4723e41b3 100644
> --- a/include/linux/slab.h
> +++ b/include/linux/slab.h
> @@ -635,6 +635,22 @@ extern void *__kmalloc_track_caller(size_t, gfp_t, unsigned long);
> #define kmalloc_track_caller(size, flags) \
> __kmalloc_track_caller(size, flags, _RET_IP_)
>
> +static inline void *kmalloc_array_node(size_t n, size_t size, gfp_t flags,
> + int node)
> +{
> + if (size != 0 && n > SIZE_MAX / size)
> + return NULL;
> + if (__builtin_constant_p(n) && __builtin_constant_p(size))
> + return kmalloc_node(n * size, flags, node);
> + return __kmalloc_node(n * size, flags, node);
> +}
> +
> +static inline void *kcalloc_node(size_t n, size_t size, gfp_t flags, int node)
> +{
> + return kmalloc_array_node(n, size, flags | __GFP_ZERO, node);
> +}
> +
> +
> #ifdef CONFIG_NUMA
> extern void *__kmalloc_node_track_caller(size_t, gfp_t, int, unsigned long);
> #define kmalloc_node_track_caller(size, flags, node) \
>
Powered by blists - more mailing lists