lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 29 Sep 2017 11:37:52 -0700
From:   Andy Lutomirski <luto@...nel.org>
To:     Josh Poimboeuf <jpoimboe@...hat.com>
Cc:     Andrey Ryabinin <aryabinin@...tuozzo.com>,
        Thomas Gleixner <tglx@...utronix.de>,
        Ingo Molnar <mingo@...hat.com>,
        "H. Peter Anvin" <hpa@...or.com>, X86 ML <x86@...nel.org>,
        Peter Zijlstra <peterz@...radead.org>,
        Andy Lutomirski <luto@...nel.org>,
        Linus Torvalds <torvalds@...ux-foundation.org>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] x86: use register variable to get stack pointer value

On Fri, Sep 29, 2017 at 8:38 AM, Josh Poimboeuf <jpoimboe@...hat.com> wrote:
> On Fri, Sep 29, 2017 at 05:15:36PM +0300, Andrey Ryabinin wrote:
>> Currently we use current_stack_pointer() function to get the value
>> of the stack pointer register. Since commit f5caf621ee35
>> ("x86/asm: Fix inline asm call constraints for Clang") we have stack
>> register variable declared. It can be used instead of current_stack_pointer()
>> function which allows to optimize away some excessive "mov %rsp, %<dst>"
>> instructions:
>>
>> -mov    %rsp,%rdx
>> -sub    %rdx,%rax
>> -cmp    $0x3fff,%rax
>> -ja     ffffffff810722fd <ist_begin_non_atomic+0x2d>
>>
>> +sub    %rsp,%rax
>> +cmp    $0x3fff,%rax
>> +ja     ffffffff810722fa <ist_begin_non_atomic+0x2a>
>>
>> Remove current_stack_pointer(), rename __asm_call_sp to current_stack_pointer
>> and use it instead of removed function.
>>
>> Signed-off-by: Andrey Ryabinin <aryabinin@...tuozzo.com>
>
> Reviewed-by: Josh Poimboeuf <jpoimboe@...hat.com>


Ok with me.  As an alternative, you could leave it as
current_stack_pointer(), but either way is fine.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ