[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <871smm6lm1.fsf@intel.com>
Date: Mon, 02 Oct 2017 10:43:18 +0300
From: Jani Nikula <jani.nikula@...ux.intel.com>
To: Jérémy Lefaure <jeremy.lefaure@....epita.fr>,
Alex Deucher <alexander.deucher@....com>,
Christian König <christian.koenig@....com>,
David Airlie <airlied@...ux.ie>,
Patrik Jakobsson <patrik.r.jakobsson@...il.com>,
Zhenyu Wang <zhenyuw@...ux.intel.com>,
Zhi Wang <zhi.a.wang@...el.com>,
Joonas Lahtinen <joonas.lahtinen@...ux.intel.com>,
Rodrigo Vivi <rodrigo.vivi@...el.com>,
Ben Skeggs <bskeggs@...hat.com>
Cc: Jérémy Lefaure <jeremy.lefaure@....epita.fr>,
amd-gfx@...ts.freedesktop.org, dri-devel@...ts.freedesktop.org,
linux-kernel@...r.kernel.org, intel-gvt-dev@...ts.freedesktop.org,
intel-gfx@...ts.freedesktop.org, nouveau@...ts.freedesktop.org
Subject: Re: [PATCH 06/18] drm: use ARRAY_SIZE
On Sun, 01 Oct 2017, Jérémy Lefaure <jeremy.lefaure@....epita.fr> wrote:
> Using the ARRAY_SIZE macro improves the readability of the code. Also,
> it is not always useful to use a variable to store this constant
> calculated at compile time nor to re-invent the ARRAY_SIZE macro.
>
> Found with Coccinelle with the following semantic patch:
> @r depends on (org || report)@
> type T;
> T[] E;
> position p;
> @@
> (
> (sizeof(E)@p /sizeof(*E))
> |
> (sizeof(E)@p /sizeof(E[...]))
> |
> (sizeof(E)@p /sizeof(T))
> )
>
> Signed-off-by: Jérémy Lefaure <jeremy.lefaure@....epita.fr>
Please split this up.
Patch 1:
> drivers/gpu/drm/amd/amdgpu/gfx_v8_0.c | 9 +++++----
> drivers/gpu/drm/amd/amdgpu/gfx_v9_0.c | 9 +++++----
Patch 2:
> drivers/gpu/drm/gma500/psb_intel_sdvo.c | 9 ++++-----
Patch 3:
> drivers/gpu/drm/i915/gvt/vgpu.c | 3 ++-
Patch 4:
> drivers/gpu/drm/nouveau/nvkm/subdev/bios/init.c | 7 ++++---
Patch 5:
> drivers/gpu/drm/via/via_verifier.c | 10 ++++------
BR,
Jani.
--
Jani Nikula, Intel Open Source Technology Center
Powered by blists - more mailing lists