[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20171012080913.g2z6uxtoyqvfbdaz@gmail.com>
Date: Thu, 12 Oct 2017 10:09:14 +0200
From: Ingo Molnar <mingo@...nel.org>
To: Andi Kleen <andi@...stfloor.org>
Cc: x86@...nel.org, linux-kernel@...r.kernel.org,
Andi Kleen <ak@...ux.intel.com>,
Thomas Gleixner <tglx@...utronix.de>
Subject: Re: [PATCH v9 3/5] x86/cpuid: Make clearcpuid an early param
* Andi Kleen <andi@...stfloor.org> wrote:
> From: Andi Kleen <ak@...ux.intel.com>
>
> Make clearcpuid= an early param, to make sure it is parsed
> before the XSAVE initialization. This allows to modify
> XSAVE state by clearing specific CPUID bits.
>
> Reviewed-by: Thomas Gleixner <tglx@...utronix.de>
> Signed-off-by: Andi Kleen <ak@...ux.intel.com>
> ---
> arch/x86/kernel/cpu/common.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/arch/x86/kernel/cpu/common.c b/arch/x86/kernel/cpu/common.c
> index fd47692e5ce9..ff51c61d2df0 100644
> --- a/arch/x86/kernel/cpu/common.c
> +++ b/arch/x86/kernel/cpu/common.c
> @@ -1310,7 +1310,7 @@ static __init int setup_disablecpuid(char *arg)
>
> return 1;
> }
> -__setup("clearcpuid=", setup_disablecpuid);
> +early_param("clearcpuid", setup_disablecpuid);
Yeah, so there's pre-existing bad naming here that should be fixed before we add
new complexity to the code: why is the option named 'clearcpuid' while the
function name is 'disablecpuid'?
Thanks,
Ingo
Powered by blists - more mailing lists