[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <d171c827-9a6d-2c45-75cb-352658f04652@kernel.org>
Date: Fri, 13 Oct 2017 20:24:15 +0800
From: Chao Yu <chao@...nel.org>
To: Yunlong Song <yunlong.song@...wei.com>, jaegeuk@...nel.org,
yuchao0@...wei.com, yunlong.song@...oud.com
Cc: linux-fsdevel@...r.kernel.org, miaoxie@...wei.com,
linux-kernel@...r.kernel.org,
linux-f2fs-devel@...ts.sourceforge.net
Subject: Re: [f2fs-dev] [PATCH] f2fs: add bug_on when f2fs_gc even fails to
get one victim
On 2017/10/13 19:20, Yunlong Song wrote:
> Yep, both are OK, since I do not care it is foreground or background. Here it just needs to do gc.
But you only set need_gc as true for foreground GC case.
Thanks,
>
> On 2017/10/13 19:09, Chao Yu wrote:
>> On 2017/10/11 21:51, Yunlong Song wrote:
>>> This can help us to debug on some corner case.
>>>
>>> Signed-off-by: Yunlong Song <yunlong.song@...wei.com>
>>> ---
>>> fs/f2fs/gc.c | 6 +++++-
>>> 1 file changed, 5 insertions(+), 1 deletion(-)
>>>
>>> diff --git a/fs/f2fs/gc.c b/fs/f2fs/gc.c
>>> index 197ebf4..960503e 100644
>>> --- a/fs/f2fs/gc.c
>>> +++ b/fs/f2fs/gc.c
>>> @@ -986,6 +986,7 @@ int f2fs_gc(struct f2fs_sb_info *sbi, bool sync,
>>> .ilist = LIST_HEAD_INIT(gc_list.ilist),
>>> .iroot = RADIX_TREE_INIT(GFP_NOFS),
>>> };
>>> + bool need_gc = false;
>> How about changing variable name to need_fggc for better readability?
>>
>> Thanks,
>>
>>> trace_f2fs_gc_begin(sbi->sb, sync, background,
>>> get_pages(sbi, F2FS_DIRTY_NODES),
>>> @@ -1018,8 +1019,10 @@ int f2fs_gc(struct f2fs_sb_info *sbi, bool sync,
>>> if (ret)
>>> goto stop;
>>> }
>>> - if (has_not_enough_free_secs(sbi, 0, 0))
>>> + if (has_not_enough_free_secs(sbi, 0, 0)) {
>>> gc_type = FG_GC;
>>> + need_gc = true;
>>> + }
>>> }
>>> /* f2fs_balance_fs doesn't need to do BG_GC in critical path. */
>>> @@ -1028,6 +1031,7 @@ int f2fs_gc(struct f2fs_sb_info *sbi, bool sync,
>>> goto stop;
>>> }
>>> if (!__get_victim(sbi, &segno, gc_type)) {
>>> + f2fs_bug_on(sbi, !total_freed && need_gc);
>>> ret = -ENODATA;
>>> goto stop;
>>> }
>>>
>> .
>>
>
Powered by blists - more mailing lists