[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20171013174605.GQ5109@tassilo.jf.intel.com>
Date: Fri, 13 Oct 2017 10:46:05 -0700
From: Andi Kleen <ak@...ux.intel.com>
To: Ingo Molnar <mingo@...nel.org>
Cc: Andi Kleen <andi@...stfloor.org>, x86@...nel.org,
linux-kernel@...r.kernel.org, Jonathan McDowell <noodles@...th.li>,
Thomas Gleixner <tglx@...utronix.de>
Subject: Re: [PATCH v9 2/5] x86/cpuid: Add generic table for cpuid
dependencies
> So instead of adding helpers the 1<< ops can be written out explicitly - they are
> easy to read after all. Can also be:
>
> var &= ~BIT(bit);
> var |= BIT(bit);
It's some more complicated because "var" are arrays.
Opencoding is fairly ugly.
I changed the main bitmap to use DECLARE_BITMAP now, which
avoids most of the casts. For accessing c->x86_capability and
cpu_caps_cleared it uses helpers now that do implicit casting.
-Andi
Powered by blists - more mailing lists