lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sat, 14 Oct 2017 17:07:29 +0200
From:   walter harms <wharms@....de>
To:     Colin King <colin.king@...onical.com>
CC:     Paul Moore <paul@...l-moore.com>,
        Stephen Smalley <sds@...ho.nsa.gov>,
        Eric Paris <eparis@...isplace.org>,
        James Morris <james.l.morris@...cle.com>,
        "Serge E . Hallyn" <serge@...lyn.com>,
        Markus Elfring <elfring@...rs.sourceforge.net>,
        selinux@...ho.nsa.gov, linux-security-module@...r.kernel.org,
        kernel-janitors@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] selinux: remove extraneous initialization of slots_used
 and max_chain_len



Am 14.10.2017 16:52, schrieb Colin King:
> From: Colin Ian King <colin.king@...onical.com>
> 
> Variables slots_used and max_chain_len are being initialized to zero
> twice. Remove the first set of initializations. Cleans up the
> clang warnings:
> 
> Value stored to 'slots_used' is never read
> Value stored to 'max_chain_len' is never read
> 
> Signed-off-by: Colin Ian King <colin.king@...onical.com>
> ---
>  security/selinux/ss/hashtab.c | 2 --
>  1 file changed, 2 deletions(-)
> 
> diff --git a/security/selinux/ss/hashtab.c b/security/selinux/ss/hashtab.c
> index bef7577d1270..622fd50c8b9c 100644
> --- a/security/selinux/ss/hashtab.c
> +++ b/security/selinux/ss/hashtab.c
> @@ -148,8 +148,6 @@ void hashtab_stat(struct hashtab *h, struct hashtab_info *info)
>  	u32 i, chain_len, slots_used, max_chain_len;
>  	struct hashtab_node *cur;
>  
> -	slots_used = 0;
> -	max_chain_len = 0;
>  	for (slots_used = max_chain_len = i = 0; i < h->size; i++) {
>  		cur = h->htable[i];
>  		if (cur) {

personally i would remove it from the for() loop. for(i=0;) is a common pattern
but setting variables this way is at least uncommon and does not improve the
readability of the code. not a good example for security related code.

just my 2 cents,
re,
 wh

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ