lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Sun, 15 Oct 2017 10:41:30 +0800
From:   Wanpeng Li <kernellwp@...il.com>
To:     Radim Krčmář <rkrcmar@...hat.com>
Cc:     "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
        kvm <kvm@...r.kernel.org>, Paolo Bonzini <pbonzini@...hat.com>,
        Wanpeng Li <wanpeng.li@...mail.com>
Subject: Re: [PATCH v2 4/4] KVM: LAPIC: Don't silently accept bad vectors

2017-10-14 4:31 GMT+08:00 Radim Krčmář <rkrcmar@...hat.com>:
> 2017-10-13 19:36+0200, Radim Krčmář:
>> 2017-10-13 09:17+0800, Wanpeng Li:
>> > 2017-10-04 22:44 GMT+08:00 Radim Krčmář <rkrcmar@...hat.com>:
>> > > 2017-10-04 22:16+0800, Wanpeng Li:
>> > >> 2017-10-04 20:01 GMT+08:00 Radim Krčmář <rkrcmar@...hat.com>:
>> > >> > 2017-10-04 15:56+0800, Wanpeng Li:
>> > >> >> 2017-10-04 1:53 GMT+08:00 Radim Krčmář <rkrcmar@...hat.com>:
>> > >> >> > 2017-09-28 18:04-0700, Wanpeng Li:
>> > >> >> >> @@ -946,6 +965,11 @@ static int __apic_accept_irq(struct kvm_lapic *apic, int delivery_mode,
>> > >> >> >>       int result = 0;
>> > >> >> >>       struct kvm_vcpu *vcpu = apic->vcpu;
>> > >> >> >>
>> > >> >> >> +     if (unlikely(vector < 16) && delivery_mode == APIC_DM_FIXED) {
>> > >> >> >> +             apic_error(apic, APIC_ESR_RECVILL);
>> > >> >> >
>> > >> >> > The error is also triggered if lowest priority is supported and tries to
>> > >> >> > deliver an invalid vector.
>> > >> >>
>> > >> >> Could you point out this in SDM? :)
>> > >> >
>> > >> > In section 10.5.3 Error Handling:
>> > >> >
>> > >> >   If the local APIC does not support the sending of lowest-priority IPIs
>> > >> >   and software writes the ICR to send a lowest-priority IPI with an
>> > >> >   illegal vector, the local APIC sets only the “redirectible IPI” error
>> > >> >   bit.
>> > >> >
>> > >> > Hence, if local APIC does support lowest-priority, then it throws the
>> > >> > same error as fixed.  (KVM does support lowest-priority.)
>> > >>
>> > >> Yeah, I read the section before but I misunderstand it. It seems that
>> > >> the section means it just occurs when the local APIC does not support
>> > >> the sending of lowest-priority IPIs?
>> > >
>> > > I think so.
>> >
>> > I see Virtualbox just captures Fixed delivery mode for error handling.
>>
>> Hm, it doesn't even inject an error on destination of the
>> lowest-priority interrupt and just drop it?

I think so.

>>
>> I can't interpret the SDM in any other way, though:
>>
>>   When an interrupt vector in the range of 0 to 15 is sent or received
>>   through the local APIC, the APIC indicates an illegal vector in its
>>   Error Status Register (see Section 10.5.3, “Error Handling”).
>>
>> and we support lowest-priority interrupts, because if we didn't, then
>>
>>  The interrupt is not processed and hence the “Send Illegal Vector” bit
>>  is not set in the ESR.
>>
>> I'll go for a quick bare-metal test ...
>
> Turns out my machine doesn't support for lowest priority IPIs (probably
> got killed with FSB), so all I get is error 0x10.

Powered by blists - more mailing lists