lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 24 Oct 2017 21:34:54 +0800
From:   Baoquan He <bhe@...hat.com>
To:     Ingo Molnar <mingo@...nel.org>
Cc:     linux-kernel@...r.kernel.org, akpm@...ux-foundation.org,
        x86@...nel.org
Subject: Re: [PATCH] x86/mm/64: Rename the argument 'size' as 'nr_pages' in
 register_page_bootmem_memmap

Hi Ingo,

On 10/24/17 at 03:29pm, Ingo Molnar wrote:
> > diff --git a/arch/x86/mm/init_64.c b/arch/x86/mm/init_64.c
> > index 048fbe8fc274..f5aa0d7c4cd1 100644
> > --- a/arch/x86/mm/init_64.c
> > +++ b/arch/x86/mm/init_64.c
> > @@ -1426,10 +1426,10 @@ int __meminit vmemmap_populate(unsigned long start, unsigned long end, int node)
> >  
> >  #if defined(CONFIG_MEMORY_HOTPLUG_SPARSE) && defined(CONFIG_HAVE_BOOTMEM_INFO_NODE)
> >  void register_page_bootmem_memmap(unsigned long section_nr,
> > -				  struct page *start_page, unsigned long size)
> > +				  struct page *start_page, unsigned long nr_pages)
> >  {
> >  	unsigned long addr = (unsigned long)start_page;
> > -	unsigned long end = (unsigned long)(start_page + size);
> > +	unsigned long end = (unsigned long)(start_page + nr_pages);
> >  	unsigned long next;
> >  	pgd_t *pgd;
> >  	p4d_t *p4d;
> 
> This doesn't build on x86-64 allyesconfig:
> 
> arch/x86/mm/init_64.c: In function ‘register_page_bootmem_memmap’:
> arch/x86/mm/init_64.c:1438:15: error: ‘nr_pages’ redeclared as different kind of symbol
> arch/x86/mm/init_64.c:1429:46: note: previous definition of ‘nr_pages’ was here
> 
> Also note that I improved the changelog (see below), could you please pick those 
> changes up for a v2 submission?

Thanks a lot for checking this and rewrote the change log.  Seems I
didn't merge the change in mm.h. Will make v2 with your patch log
changes and repost after testing.

Thanks
Baoquan


> 
> 
> ==================>
> From 67780ebe5c99190d2a946de106bd0c7b83e11b68 Mon Sep 17 00:00:00 2001
> From: Baoquan He <bhe@...hat.com>
> Date: Tue, 24 Oct 2017 20:47:29 +0800
> Subject: [PATCH] x86/mm/64: Rename the register_page_bootmem_memmap() 'size' parameter to 'nr_pages'
> 
> register_page_bootmem_memmap()'s 3rd 'size' parameter is named
> in a somewhat misleading fashion - rename it to 'nr_pages' which
> makes the units of it much clearer.
> 
> Signed-off-by: Baoquan He <bhe@...hat.com>
> Cc: Linus Torvalds <torvalds@...ux-foundation.org>
> Cc: Peter Zijlstra <peterz@...radead.org>
> Cc: Thomas Gleixner <tglx@...utronix.de>
> Cc: akpm@...ux-foundation.org
> Link: http://lkml.kernel.org/r/1508849249-18035-1-git-send-email-bhe@redhat.com
> Signed-off-by: Ingo Molnar <mingo@...nel.org>
> ---
>  arch/x86/mm/init_64.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/arch/x86/mm/init_64.c b/arch/x86/mm/init_64.c
> index 048fbe8fc274..f5aa0d7c4cd1 100644
> --- a/arch/x86/mm/init_64.c
> +++ b/arch/x86/mm/init_64.c
> @@ -1426,10 +1426,10 @@ int __meminit vmemmap_populate(unsigned long start, unsigned long end, int node)
>  
>  #if defined(CONFIG_MEMORY_HOTPLUG_SPARSE) && defined(CONFIG_HAVE_BOOTMEM_INFO_NODE)
>  void register_page_bootmem_memmap(unsigned long section_nr,
> -				  struct page *start_page, unsigned long size)
> +				  struct page *start_page, unsigned long nr_pages)
>  {
>  	unsigned long addr = (unsigned long)start_page;
> -	unsigned long end = (unsigned long)(start_page + size);
> +	unsigned long end = (unsigned long)(start_page + nr_pages);
>  	unsigned long next;
>  	pgd_t *pgd;
>  	p4d_t *p4d;

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ