lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 2 Nov 2017 08:11:07 -0700
From:   Alexei Starovoitov <ast@...com>
To:     Roman Gushchin <guro@...com>, <netdev@...r.kernel.org>
CC:     Tejun Heo <tj@...nel.org>, Alexei Starovoitov <ast@...nel.org>,
        Daniel Borkmann <daniel@...earbox.net>,
        <linux-kernel@...r.kernel.org>, <kernel-team@...com>
Subject: Re: [PATCH v2 net-next 3/5] bpf, cgroup: implement eBPF-based device
 controller for cgroup v2

On 11/2/17 7:54 AM, Roman Gushchin wrote:
> +#define DEV_BPF_ACC_MKNOD	(1ULL << 0)
> +#define DEV_BPF_ACC_READ	(1ULL << 1)
> +#define DEV_BPF_ACC_WRITE	(1ULL << 2)
> +
> +#define DEV_BPF_DEV_BLOCK	(1ULL << 0)
> +#define DEV_BPF_DEV_CHAR	(1ULL << 1)
> +

all macros in bpf.h start with BPF_
To be consistent with the rest can you rename above to BPF_DEVCG_.. ?

Powered by blists - more mailing lists