[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <1510552144-20831-1-git-send-email-douly.fnst@cn.fujitsu.com>
Date: Mon, 13 Nov 2017 13:49:04 +0800
From: Dou Liyang <douly.fnst@...fujitsu.com>
To: <linux-kernel@...r.kernel.org>
CC: <tglx@...utronix.de>, <mingo@...hat.com>, <hpa@...or.com>,
<john.stultz@...aro.org>, <deepa.kernel@...il.com>,
<pombredanne@...b.com>, <gregkh@...uxfoundation.org>,
<arnd@...db.de>, <joelaf@...gle.com>,
Dou Liyang <douly.fnst@...fujitsu.com>
Subject: [PATCH] timekeeping: Eliminate the useless declaration of ktime_get_raw_and_real_ts64()
Commit:
ba26621e63ce ("time: Remove duplicated code in ktime_get_raw_and_real()")
... got rid of ktime_get_raw_and_real_ts64(), but left its declaration
behind.
Remove it.
Signed-off-by: Dou Liyang <douly.fnst@...fujitsu.com>
---
include/linux/timekeeping.h | 6 ------
1 file changed, 6 deletions(-)
diff --git a/include/linux/timekeeping.h b/include/linux/timekeeping.h
index c198ab4..b17bcce 100644
--- a/include/linux/timekeeping.h
+++ b/include/linux/timekeeping.h
@@ -143,12 +143,6 @@ extern bool timekeeping_rtc_skipresume(void);
extern void timekeeping_inject_sleeptime64(struct timespec64 *delta);
/*
- * PPS accessor
- */
-extern void ktime_get_raw_and_real_ts64(struct timespec64 *ts_raw,
- struct timespec64 *ts_real);
-
-/*
* struct system_time_snapshot - simultaneous raw/real time capture with
* counter value
* @cycles: Clocksource counter value to produce the system times
--
2.5.5
Powered by blists - more mailing lists