[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <tip-558de28249508dc3ec0ec8981d1315eb8b63f0d9@git.kernel.org>
Date: Tue, 14 Nov 2017 02:24:41 -0800
From: tip-bot for Benjamin Gaignard <tipbot@...or.com>
To: linux-tip-commits@...r.kernel.org
Cc: linux-kernel@...r.kernel.org, mingo@...nel.org, hpa@...or.com,
tglx@...utronix.de, benjamin.gaignard@...aro.org
Subject: [tip:timers/urgent] clocksource/timer_of: Rename timer_of_exit to
timer_of_cleanup
Commit-ID: 558de28249508dc3ec0ec8981d1315eb8b63f0d9
Gitweb: https://git.kernel.org/tip/558de28249508dc3ec0ec8981d1315eb8b63f0d9
Author: Benjamin Gaignard <benjamin.gaignard@...aro.org>
AuthorDate: Tue, 14 Nov 2017 09:52:38 +0100
Committer: Thomas Gleixner <tglx@...utronix.de>
CommitDate: Tue, 14 Nov 2017 11:20:24 +0100
clocksource/timer_of: Rename timer_of_exit to timer_of_cleanup
Change the function name to something more explicit since it is only used
in init error cases.
Add __init annotation and description about the function usage.
Signed-off-by: Benjamin Gaignard <benjamin.gaignard@...aro.org>
Signed-off-by: Thomas Gleixner <tglx@...utronix.de>
Cc: mark.rutland@....com
Cc: devicetree@...r.kernel.org
Cc: alexandre.torgue@...com
Cc: arnd@...db.de
Cc: julien.thierry@....com
Cc: daniel.lezcano@...aro.org
Cc: linux@...linux.org.uk
Cc: robh+dt@...nel.org
Cc: linux-arm-kernel@...ts.infradead.org
Cc: mcoquelin.stm32@...il.com
Cc: sudeep.holla@....com
Cc: ludovic.barre@...com
Link: https://lkml.kernel.org/r/1510649563-22975-2-git-send-email-benjamin.gaignard@linaro.org
---
drivers/clocksource/timer-of.c | 9 ++++++++-
drivers/clocksource/timer-of.h | 2 +-
2 files changed, 9 insertions(+), 2 deletions(-)
diff --git a/drivers/clocksource/timer-of.c b/drivers/clocksource/timer-of.c
index 7c64a5c1..a319904 100644
--- a/drivers/clocksource/timer-of.c
+++ b/drivers/clocksource/timer-of.c
@@ -177,7 +177,14 @@ out_fail:
return ret;
}
-void timer_of_exit(struct timer_of *to)
+/**
+ * timer_of_cleanup - release timer_of ressources
+ * @to: timer_of structure
+ *
+ * Release the ressources that has been used in timer_of_init().
+ * This function should be called in init error cases
+ */
+void __init timer_of_cleanup(struct timer_of *to)
{
if (to->flags & TIMER_OF_IRQ)
timer_irq_exit(&to->of_irq);
diff --git a/drivers/clocksource/timer-of.h b/drivers/clocksource/timer-of.h
index 43f5ba3..3f708f1 100644
--- a/drivers/clocksource/timer-of.h
+++ b/drivers/clocksource/timer-of.h
@@ -68,6 +68,6 @@ static inline unsigned long timer_of_period(struct timer_of *to)
extern int __init timer_of_init(struct device_node *np,
struct timer_of *to);
-extern void timer_of_exit(struct timer_of *to);
+extern void __init timer_of_cleanup(struct timer_of *to);
#endif
Powered by blists - more mailing lists