lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 17 Nov 2017 10:27:10 -0200
From:   Gustavo Padovan <gustavo@...ovan.org>
To:     Mauro Carvalho Chehab <mchehab@....samsung.com>
Cc:     linux-media@...r.kernel.org, Hans Verkuil <hverkuil@...all.nl>,
        Shuah Khan <shuahkh@....samsung.com>,
        Pawel Osciak <pawel@...iak.com>,
        Alexandre Courbot <acourbot@...omium.org>,
        Sakari Ailus <sakari.ailus@....fi>,
        Brian Starkey <brian.starkey@....com>,
        Thierry Escande <thierry.escande@...labora.com>,
        linux-kernel@...r.kernel.org,
        Gustavo Padovan <gustavo.padovan@...labora.com>
Subject: Re: [RFC v5 03/11] [media] vb2: add 'ordered_in_driver' property to
 queues

Hi Mauro,

2017-11-17 Mauro Carvalho Chehab <mchehab@....samsung.com>:

> Em Wed, 15 Nov 2017 15:10:49 -0200
> Gustavo Padovan <gustavo@...ovan.org> escreveu:
> 
> > From: Gustavo Padovan <gustavo.padovan@...labora.com>
> > 
> > We use ordered_in_driver property to optimize for the case where
> > the driver can deliver the buffers in an ordered fashion. When it
> > is ordered we can use the same fence context for all fences, but
> > when it is not we need to a new context for each out-fence.
> > 
> > So the ordered_in_driver flag will help us with identifying the queues
> > that can be optimized and use the same fence context.
> > 
> > v4: make the property a vector for optimization and not a mandatory thing
> > that drivers need to set if they want to use explicit synchronization.
> > 
> > v3: improve doc (Hans Verkuil)
> > 
> > v2: rename property to 'ordered_in_driver' to avoid confusion
> > 
> > Signed-off-by: Gustavo Padovan <gustavo.padovan@...labora.com>
> > ---
> >  include/media/videobuf2-core.h | 7 +++++++
> >  1 file changed, 7 insertions(+)
> > 
> > diff --git a/include/media/videobuf2-core.h b/include/media/videobuf2-core.h
> > index ef9b64398c8c..38b9c8dd42c6 100644
> > --- a/include/media/videobuf2-core.h
> > +++ b/include/media/videobuf2-core.h
> > @@ -440,6 +440,12 @@ struct vb2_buf_ops {
> >   * @fileio_read_once:		report EOF after reading the first buffer
> >   * @fileio_write_immediately:	queue buffer after each write() call
> >   * @allow_zero_bytesused:	allow bytesused == 0 to be passed to the driver
> > + * @ordered_in_driver: if the driver can guarantee that the queue will be
> > + *		ordered or not, i.e., the buffers are dequeued from the driver
> > + *		in the same order they are queued to the driver. The default
> > + *		is not ordered unless the driver sets this flag. Setting it
> > + *		when ordering can be guaranted helps to optimize explicit
> > + *		fences.
> >   * @quirk_poll_must_check_waiting_for_buffers: Return POLLERR at poll when QBUF
> >   *              has not been called. This is a vb1 idiom that has been adopted
> >   *              also by vb2.
> > @@ -510,6 +516,7 @@ struct vb2_queue {
> >  	unsigned			fileio_read_once:1;
> >  	unsigned			fileio_write_immediately:1;
> >  	unsigned			allow_zero_bytesused:1;
> > +	unsigned			ordered_in_driver:1;
> 
> As this may depend on the format, it is probably a good idea to set
> this flag either via a function argument or by a function that
> would be meant to update it, as video format changes.

Right, and maybe I can find a way to store this in only one place,
istead of what I did here (having to set explicitely both the 
ordered_in_driver and the flag separatedly)

Gustavo

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ