lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Wed, 22 Nov 2017 09:50:03 -0200
From:   Guilherme Tadashi Maeoka <gui.maeoka@...il.com>
To:     "Tobin C. Harding" <me@...in.cc>
Cc:     abbotti@....co.uk, devel@...verdev.osuosl.org,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH] Staging: comedi: adl_pci9118: fixed some parentheses
 coding style issue

Thank you. I'll keep that in mind next time!

On Wed, Nov 22, 2017 at 11:28:51AM +1100, Tobin C. Harding wrote:
> You may like to limit the git log brief description to 50 characters
> (this is going to be hard with such a long pre-fix though :)
> 
> Brief description should be in imperative mood i.e 'Fix foo' instead of
> 'fixed foo'.
> 
> On Tue, Nov 21, 2017 at 05:17:53PM -0200, Guilherme Tadashi Maeoka wrote:
> > Fixed some code style issues.
> 
> This is not descriptive enough. You may like to read
> 
> 	Documentation/process/submitting-patches.rst
> 
> for tips on writing git log messages. 
> 
> > Signed-off-by: Guilherme Tadashi Maeoka <gui.maeoka@...il.com>
> > ---
> >  drivers/staging/comedi/drivers/adl_pci9118.c | 12 ++++++------
> >  1 file changed, 6 insertions(+), 6 deletions(-)
> > 
> > diff --git a/drivers/staging/comedi/drivers/adl_pci9118.c b/drivers/staging/comedi/drivers/adl_pci9118.c
> > index 1cc9b7ef1ff9..53f13994ac94 100644
> > --- a/drivers/staging/comedi/drivers/adl_pci9118.c
> > +++ b/drivers/staging/comedi/drivers/adl_pci9118.c
> > @@ -947,7 +947,7 @@ static int pci9118_ai_cmd(struct comedi_device *dev, struct comedi_subdevice *s)
> >  	if (devpriv->master) {
> >  		devpriv->usedma = 1;
> >  		if ((cmd->flags & CMDF_WAKE_EOS) &&
> > -		    (cmd->scan_end_arg == 1)) {
> > +		    cmd->scan_end_arg == 1) {
> 
> The code was easier to read before this change IMO.
> 
> >  			if (cmd->convert_src == TRIG_NOW)
> >  				devpriv->ai_add_back = 1;
> >  			if (cmd->convert_src == TRIG_TIMER) {
> > @@ -960,7 +960,7 @@ static int pci9118_ai_cmd(struct comedi_device *dev, struct comedi_subdevice *s)
> >  		}
> >  		if ((cmd->flags & CMDF_WAKE_EOS) &&
> >  		    (cmd->scan_end_arg & 1) &&
> > -		    (cmd->scan_end_arg > 1)) {
> > +		    cmd->scan_end_arg > 1) {
> >  			if (cmd->scan_begin_src == TRIG_FOLLOW) {
> >  				devpriv->usedma = 0;
> >  				/*
> > @@ -983,7 +983,7 @@ static int pci9118_ai_cmd(struct comedi_device *dev, struct comedi_subdevice *s)
> >  	 */
> >  	if (cmd->convert_src == TRIG_NOW && devpriv->softsshdelay) {
> >  		devpriv->ai_add_front = 2;
> > -		if ((devpriv->usedma == 1) && (devpriv->ai_add_back == 1)) {
> > +		if (devpriv->usedma == 1 && devpriv->ai_add_back == 1) {
> 
> Likewise, this is not making the code easier to read.
> 
> >  							/* move it to front */
> >  			devpriv->ai_add_front++;
> >  			devpriv->ai_add_back = 0;
> > @@ -1185,7 +1185,7 @@ static int pci9118_ai_cmdtest(struct comedi_device *dev,
> >  	    (!(cmd->convert_src & (TRIG_TIMER | TRIG_NOW))))
> >  		err |= -EINVAL;
> >  
> > -	if ((cmd->scan_begin_src == TRIG_FOLLOW) &&
> > +	if (cmd->scan_begin_src == TRIG_FOLLOW &&
> >  	    (!(cmd->convert_src & (TRIG_TIMER | TRIG_EXT))))
> >  		err |= -EINVAL;
> >  
> > @@ -1210,8 +1210,8 @@ static int pci9118_ai_cmdtest(struct comedi_device *dev,
> >  	if (cmd->scan_begin_src & (TRIG_FOLLOW | TRIG_EXT))
> >  		err |= comedi_check_trigger_arg_is(&cmd->scan_begin_arg, 0);
> >  
> > -	if ((cmd->scan_begin_src == TRIG_TIMER) &&
> > -	    (cmd->convert_src == TRIG_TIMER) && (cmd->scan_end_arg == 1)) {
> > +	if (cmd->scan_begin_src == TRIG_TIMER &&
> > +	    cmd->convert_src == TRIG_TIMER && cmd->scan_end_arg == 1) {
> >  		cmd->scan_begin_src = TRIG_FOLLOW;
> >  		cmd->convert_arg = cmd->scan_begin_arg;
> >  		cmd->scan_begin_arg = 0;
> 
> Remember, we are writing code for developers to read. It should be as
> easy to parse as possible.
> 
> Hope this helps,
> Tobin.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ