lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 23 Nov 2017 15:11:31 +0100
From:   Greg KH <gregkh@...uxfoundation.org>
To:     Oded Gabbay <oded.gabbay@...il.com>
Cc:     linux-kernel@...r.kernel.org, linux-pci@...r.kernel.org
Subject: Re: [PATCH] pci: add class codes for processing accelerators

On Thu, Nov 23, 2017 at 04:04:22PM +0200, Oded Gabbay wrote:
> Add PCI codes to include/linux/pci_ids.h for Processing Accelerators. There
> are new ASICs (now in development) for Deep Learning that will utilize this
> base class.
> 
> Signed-off-by: Oded Gabbay <oded.gabbay@...il.com>
> ---
>  include/linux/pci_ids.h | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
> index ab20dc5..4c210cd 100644
> --- a/include/linux/pci_ids.h
> +++ b/include/linux/pci_ids.h
> @@ -139,6 +139,9 @@
>  #define PCI_CLASS_SP_DPIO		0x1100
>  #define PCI_CLASS_SP_OTHER		0x1180
>  
> +#define PCI_BASE_CLASS_PROCESSING_ACCELERATOR	0x12
> +#define PCI_CLASS_PA_VENDOR_SPECIFIC		0x1200

Did you read the top of this file?

And if these really do belong here, then it should go in as part of a
patch series that contains a driver that uses these values.

thanks,

greg k-h

Powered by blists - more mailing lists