lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Sat, 25 Nov 2017 09:26:38 -0800
From:   Andy Lutomirski <>
To:     Borislav Petkov <>
Cc:     Thomas Gleixner <>,
        Ingo Molnar <>,
        "" <>,
        Dave Hansen <>,
        "H . Peter Anvin" <>,
        Peter Zijlstra <>,
        Linus Torvalds <>
Subject: Re: [PATCH 20/43] x86/entry: Clean up SYSENTER_stack code

On Sat, Nov 25, 2017 at 9:10 AM, Borislav Petkov <> wrote:
> On Sat, Nov 25, 2017 at 06:03:36PM +0100, Thomas Gleixner wrote:
>> > Maybe I should rename cpu_tss to cpu_tss_rw in that patch.
>> For clarity that would be nice.
> + a comment stating the alias mapping. It took tglx and me a while on
> IRC to figure it out. :-)

I'm adding this comment to the top of cpu_entry_area:

+ * Every field is a virtual alias of some other allocated backing store.
+ * There is no direct allocation of a struct cpu_entry_area.

Powered by blists - more mailing lists