lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 29 Nov 2017 17:38:15 +0200
From:   Jarkko Sakkinen <>
To:     Sean Christopherson <>
Cc:,,, Thomas Gleixner <>,
        Ingo Molnar <>,
        "H. Peter Anvin" <>, Borislav Petkov <>,
        Janakarajan Natarajan <>,
        Paolo Bonzini <>,
        "Kirill A. Shutemov" <>,
        Kyle Huey <>,
        Vikas Shivappa <>,
        Piotr Luc <>,
        Grzegorz Andrejczuk <>
Subject: Re: [PATCH v6 04/11] x86: define IA32_FEATUE_CONTROL.SGX_LC

On Wed, Nov 29, 2017 at 12:21:41AM +0200, Jarkko Sakkinen wrote:
> On Tue, Nov 28, 2017 at 02:00:03PM -0800, Sean Christopherson wrote:
> > What about SGX_LC_ENABLE?  The title in the MSR section of the SDM is
> > "SGX Launch Control Enable", and it's more consistent with the other
> > bits defined in feature control.  I'd also prefer that name for the
> > actual #define too, SGX_LAUNCH_CONTROL_ENABLE is overly verbose IMO.
> This is a bit ugly name but it is also very clear:
> Just pushed update to the le branch. SGX_LC_ENABLE is a nice short name
> but it does not reflect the semantics.
> Maybe we could combine these and name it as
> It is not as ugly and is very clear what it does.

I ended up with FEATURE_CONTROL_SGX_LC_WR. I think that is fairly
reasonable name for bit 17.


Powered by blists - more mailing lists