[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <201712012202.BDE13557.MJFQLtOOHVOFSF@I-love.SAKURA.ne.jp>
Date: Fri, 1 Dec 2017 22:02:01 +0900
From: Tetsuo Handa <penguin-kernel@...ove.SAKURA.ne.jp>
To: wei.w.wang@...el.com
Cc: virtio-dev@...ts.oasis-open.org, linux-kernel@...r.kernel.org,
qemu-devel@...gnu.org, virtualization@...ts.linux-foundation.org,
kvm@...r.kernel.org, linux-mm@...ck.org, mst@...hat.com,
mhocko@...nel.org, akpm@...ux-foundation.org,
mawilcox@...rosoft.com, david@...hat.com, cornelia.huck@...ibm.com,
mgorman@...hsingularity.net, aarcange@...hat.com,
amit.shah@...hat.com, pbonzini@...hat.com, willy@...radead.org,
liliang.opensource@...il.com, yang.zhang.wz@...il.com,
quan.xu@...yun.com, nilal@...hat.com, riel@...hat.com
Subject: Re: [PATCH v18 05/10] xbitmap: add more operations
Wei Wang wrote:
> On 11/30/2017 06:34 PM, Tetsuo Handa wrote:
> > Wei Wang wrote:
> >> + * @start: the start of the bit range, inclusive
> >> + * @end: the end of the bit range, inclusive
> >> + *
> >> + * This function is used to clear a bit in the xbitmap. If all the bits of the
> >> + * bitmap are 0, the bitmap will be freed.
> >> + */
> >> +void xb_clear_bit_range(struct xb *xb, unsigned long start, unsigned long end)
> >> +{
> >> + struct radix_tree_root *root = &xb->xbrt;
> >> + struct radix_tree_node *node;
> >> + void **slot;
> >> + struct ida_bitmap *bitmap;
> >> + unsigned int nbits;
> >> +
> >> + for (; start < end; start = (start | (IDA_BITMAP_BITS - 1)) + 1) {
> >> + unsigned long index = start / IDA_BITMAP_BITS;
> >> + unsigned long bit = start % IDA_BITMAP_BITS;
> >> +
> >> + bitmap = __radix_tree_lookup(root, index, &node, &slot);
> >> + if (radix_tree_exception(bitmap)) {
> >> + unsigned long ebit = bit + 2;
> >> + unsigned long tmp = (unsigned long)bitmap;
> >> +
> >> + nbits = min(end - start + 1, BITS_PER_LONG - ebit);
> > "nbits = min(end - start + 1," seems to expect that start == end is legal
> > for clearing only 1 bit. But this function is no-op if start == end.
> > Please clarify what "inclusive" intended.
>
> If xb_clear_bit_range(xb,10,10), then it is effectively the same as
> xb_clear_bit(10). Why would it be illegal?
>
> "@start inclusive" means that the @start will also be included to be
> cleared.
If start == end is legal,
for (; start < end; start = (start | (IDA_BITMAP_BITS - 1)) + 1) {
makes this loop do nothing because 10 < 10 is false.
>
> >
> >> +static inline __always_inline void bitmap_clear(unsigned long *map,
> >> + unsigned int start,
> >> + unsigned int nbits)
> >> +{
> >> + if (__builtin_constant_p(nbits) && nbits == 1)
> >> + __clear_bit(start, map);
> >> + else if (__builtin_constant_p(start & 7) && IS_ALIGNED(start, 8) &&
> >> + __builtin_constant_p(nbits & 7) && IS_ALIGNED(nbits, 8))
> > It looks strange to apply __builtin_constant_p test to variables after "& 7".
> >
>
> I think this is normal - if the variables are known at compile time, the
> calculation will be done at compile time (termed constant folding).
I think that
+ else if (__builtin_constant_p(start) && IS_ALIGNED(start, 8) &&
+ __builtin_constant_p(nbits) && IS_ALIGNED(nbits, 8))
is more readable.
Powered by blists - more mailing lists