lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <d7ab4a17-8551-5134-95e4-df15944623c5@axentia.se>
Date:   Mon, 4 Dec 2017 17:18:11 +0100
From:   Peter Rosin <peda@...ntia.se>
To:     Hans de Goede <hdegoede@...hat.com>
Cc:     Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH resend v2] mux: core: Fix double get_device()

On 2017-11-28 10:05, Hans de Goede wrote:
> class_find_device already does a get_device on the returned device.
> So the device returned by of_find_mux_chip_by_node is already referenced
> and we should not reference it again (and unref it on error).
> 
> Also rename of_find_mux_chip_by_node to of_get_mux_chip_by_node to
> make it clear that it returns a reference.

Yep, I forgot. Sorry about that. I'll try to do better this time...

Cheers,
Peter

> Signed-off-by: Hans de Goede <hdegoede@...hat.com>
> ---
> Changes in v2:
> -Do not rename of_find_mux_chip_by_node
> ---
>  drivers/mux/core.c | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/mux/core.c b/drivers/mux/core.c
> index 2260063b0ea8..6e5cf9d9cd99 100644
> --- a/drivers/mux/core.c
> +++ b/drivers/mux/core.c
> @@ -413,6 +413,7 @@ static int of_dev_node_match(struct device *dev, const void *data)
>  	return dev->of_node == data;
>  }
>  
> +/* Note this function returns a reference to the mux_chip dev. */
>  static struct mux_chip *of_find_mux_chip_by_node(struct device_node *np)
>  {
>  	struct device *dev;
> @@ -466,6 +467,7 @@ struct mux_control *mux_control_get(struct device *dev, const char *mux_name)
>  	    (!args.args_count && (mux_chip->controllers > 1))) {
>  		dev_err(dev, "%pOF: wrong #mux-control-cells for %pOF\n",
>  			np, args.np);
> +		put_device(&mux_chip->dev);
>  		return ERR_PTR(-EINVAL);
>  	}
>  
> @@ -476,10 +478,10 @@ struct mux_control *mux_control_get(struct device *dev, const char *mux_name)
>  	if (controller >= mux_chip->controllers) {
>  		dev_err(dev, "%pOF: bad mux controller %u specified in %pOF\n",
>  			np, controller, args.np);
> +		put_device(&mux_chip->dev);
>  		return ERR_PTR(-EINVAL);
>  	}
>  
> -	get_device(&mux_chip->dev);
>  	return &mux_chip->mux[controller];
>  }
>  EXPORT_SYMBOL_GPL(mux_control_get);
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ