[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <27ee1755-76d8-f086-5760-9c973b31108a@nvidia.com>
Date: Wed, 6 Dec 2017 00:06:52 -0800
From: John Hubbard <jhubbard@...dia.com>
To: Florian Weimer <fweimer@...hat.com>,
Matthew Wilcox <willy@...radead.org>,
Michael Ellerman <mpe@...erman.id.au>
CC: Cyril Hrubis <chrubis@...e.cz>, Michal Hocko <mhocko@...nel.org>,
Kees Cook <keescook@...omium.org>,
Linux API <linux-api@...r.kernel.org>,
Khalid Aziz <khalid.aziz@...cle.com>,
Andrew Morton <akpm@...ux-foundation.org>,
Russell King - ARM Linux <linux@...linux.org.uk>,
Andrea Arcangeli <aarcange@...hat.com>,
Linux-MM <linux-mm@...ck.org>,
LKML <linux-kernel@...r.kernel.org>,
linux-arch <linux-arch@...r.kernel.org>,
Abdul Haleem <abdhalee@...ux.vnet.ibm.com>,
Joel Stanley <joel@....id.au>
Subject: Re: [PATCH 0/2] mm: introduce MAP_FIXED_SAFE
On 12/05/2017 11:35 PM, Florian Weimer wrote:
> On 12/06/2017 08:33 AM, John Hubbard wrote:
>> In that case, maybe:
>>
>> MAP_EXACT
>>
>> ? ...because that's the characteristic behavior.
>
> Is that true? mmap still silently rounding up the length to the page size, I assume, so even that name is misleading.
Hi Florian,
Not as far as I can tell, it's not doing that.
For both MAP_FIXED, and this new flag, the documented (and actual)
behavior is *not* to do any such rounding. Instead, the requested
input address is required to be page-aligned itself, and mmap()
should be honoring the exact addr.
>From the mmap(2) man page:
MAP_FIXED
Don't interpret addr as a hint: place the mapping at
exactly that address. addr must be a multiple of the
page size.
And from what I can see, the do_mmap() implementation leaves addr
unchanged, in the MAP_FIXED case:
do_mmap(...)
{
/* ... */
if (!(flags & MAP_FIXED))
addr = round_hint_to_min(addr);
...although it does look like device drivers have the opportunity
to break that:
mmap_region(...)
{
/* Can addr have changed??
*
* Answer: Yes, several device drivers can do it in their
* f_op->mmap method. -DaveM
* Bug: If addr is changed, prev, rb_link, rb_parent should
* be updated for vma_link()
*/
WARN_ON_ONCE(addr != vma->vm_start);
addr = vma->vm_start;
--
thanks,
John Hubbard
NVIDIA
>
> Thanks,
> Florian
Powered by blists - more mailing lists