lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 6 Dec 2017 14:34:01 +0100
From:   "Rafael J. Wysocki" <rafael@...nel.org>
To:     Chris Chiu <chiu@...lessm.com>
Cc:     "Rafael J. Wysocki" <rjw@...ysocki.net>,
        "Rafael J. Wysocki" <rafael@...nel.org>,
        ACPI Devel Maling List <linux-acpi@...r.kernel.org>,
        Linux Kernel <linux-kernel@...r.kernel.org>,
        Len Brown <lenb@...nel.org>,
        Linux Upstreaming Team <linux@...lessm.com>
Subject: Re: GemniLake laptops goes power off directly after performing suspend

On Wed, Dec 6, 2017 at 10:33 AM, Chris Chiu <chiu@...lessm.com> wrote:
> On Wed, Dec 6, 2017 at 5:56 AM, Rafael J. Wysocki <rjw@...ysocki.net> wrote:
>> On Tuesday, December 5, 2017 5:19:03 PM CET Chris Chiu wrote:
>>> On Tue, Dec 5, 2017 at 11:01 PM, Rafael J. Wysocki <rafael@...nel.org> wrote:
>>> > On Tue, Dec 5, 2017 at 11:32 AM, Chris Chiu <chiu@...lessm.com> wrote:
>>> >> Hi,
>>> >>     I have 2 GemniLake laptops from ASUS, named X441MB and X507MA,
>>> >> both go power off after I do "systemctl suspend" on top of kerne head
>>> >> fd6d2e506ce6 (Merge tag 'docs-4.15-fixes' of git://git.lwn.net/linux).
>>> >> I then wipe it out and install Windows RS3 instead, also goes to power
>>> >> off after pressing media key for suspend(S3). Then I installed intel
>>> >> graphic driver with the following version number, Windows has no
>>> >> problem on suspend resume then.
>>> >
>>> > There is a suspend-related fix missing in 4.15-rc at this point, so
>>> > please test 4.14.y or wait for the fix to be merged.
>>> >
>>> > Thanks,
>>> > Rafael
>>>
>>> You mean the suspend-related fix used to exist in 4.14? Could you point me
>>> out which commit it is? Thanks
>>
>> No.
>>
>> I mean that suspend generally works in 4.14 and is currently broken
>> in 4.15-rc which requires a fix to be applied.  The fix in question is at:
>>
>> https://lkml.org/lkml/2017/11/30/546
>>
>> This is needed due to some changes made in 4.15-rc (with respect to 4.14)
>> that broke resume from suspend to RAM.
>>
>> Thanks,
>> Rafael
>>
>
> I think maybe for GemniLake is a different issue. I tried Ubuntu-4.14.0-11.13
> kernel and 4.13 kernel. Both go power off immediately.

OK, so yes, this is a different issue.

Is that suspend-to-idle or suspend-to-RAM (ACPI S3)?

Powered by blists - more mailing lists