lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 06 Dec 2017 14:50:17 +0000
From:   David Howells <>
To:     James Morris <>
Cc:, Colin King <>,
        "Serge E . Hallyn" <>,,,,
Subject: Re: [PATCH] security: keys: remove redundant assignment to key_ref

James Morris <> wrote:

> I think a general cleanup in that function to make all of these follow the 
> pattern:
> 	if (something) {
> 		key_ref = ERR_PTR(-error);
> 		goto error;
> 	}
> rather than unconditionally setting the error first, would be better, but 
> this is a clear enough fix on its own.

There's a preference in Linux to use:

	key_ref = ERR_PTR(-error);
 	if (something)
 		goto error;

instead because it uses less vertical space.  It might originally have been
promulgated by Linus, but I don't remember.  Though you do have a point - your
way makes error handling less subject breakage from code rearrangement.


Powered by blists - more mailing lists