[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAHp75VfSe33bnTymjoTOMPMdXntne9FCn7EvWxY4NJeh=0+Ykg@mail.gmail.com>
Date: Sun, 10 Dec 2017 15:10:31 +0200
From: Andy Shevchenko <andy.shevchenko@...il.com>
To: Bartosz Golaszewski <brgl@...ev.pl>
Cc: Mark Brown <broonie@...nel.org>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH] regmap: allow to disable all locking mechanisms
On Wed, Dec 6, 2017 at 4:26 PM, Bartosz Golaszewski <brgl@...ev.pl> wrote:
> We have a use case in the at24 EEPROM driver (recently converted to
> using regmap instead of raw i2c/smbus calls) where we read from/write
> to the regmap in a loop, while protecting the entire loop with
> a mutex.
>
> Currently this implicitly makes us use two mutexes - one in the driver
> and one in regmap. While browsing the code for similar use cases I
> noticed a significant number of places where locking *seems* redundant.
>
> Allow users to completely disable any locking mechanisms in regmap
> config.
> +static void regmap_lock_unlock_empty(void *__map)
..._none()?
> +{
> +
> +}
> +
> static void regmap_lock_mutex(void *__map)
> - if (config->lock && config->unlock) {
> + if (config->disable_locking) {
> + map->lock = map->unlock = regmap_lock_unlock_empty;
> + } else if (config->lock && config->unlock) {
Why not to introduce positive switch, namely
bool mutex_lock; // choose better name
and assign ..._none() by default?
--
With Best Regards,
Andy Shevchenko
Powered by blists - more mailing lists