[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20180207050200.GH3617@linux.vnet.ibm.com>
Date: Tue, 6 Feb 2018 21:02:00 -0800
From: "Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>
To: Matthew Wilcox <willy@...radead.org>
Cc: Kirill Tkhai <ktkhai@...tuozzo.com>, josh@...htriplett.org,
rostedt@...dmis.org, mathieu.desnoyers@...icios.com,
jiangshanlai@...il.com, mingo@...hat.com, cl@...ux.com,
penberg@...nel.org, rientjes@...gle.com, iamjoonsoo.kim@....com,
akpm@...ux-foundation.org, linux-kernel@...r.kernel.org,
linux-mm@...ck.org, brouer@...hat.com, rao.shoaib@...cle.com
Subject: Re: [PATCH 0/2] rcu: Transform kfree_rcu() into kvfree_rcu()
On Tue, Feb 06, 2018 at 08:23:34PM -0800, Matthew Wilcox wrote:
> On Tue, Feb 06, 2018 at 06:17:03PM -0800, Paul E. McKenney wrote:
> > So it is OK to kvmalloc() something and pass it to either kfree() or
> > kvfree(), and it had better be OK to kvmalloc() something and pass it
> > to kvfree().
> >
> > Is it OK to kmalloc() something and pass it to kvfree()?
>
> Yes, it absolutely is.
>
> void kvfree(const void *addr)
> {
> if (is_vmalloc_addr(addr))
> vfree(addr);
> else
> kfree(addr);
> }
>
> > If so, is it really useful to have two different names here, that is,
> > both kfree_rcu() and kvfree_rcu()?
>
> I think it's handy to have all three of kvfree_rcu(), kfree_rcu() and
> vfree_rcu() available in the API for the symmetry of calling kmalloc()
> / kfree_rcu().
>
> Personally, I would like us to rename kvfree() to just free(), and have
> malloc(x) be an alias to kvmalloc(x, GFP_KERNEL), but I haven't won that
> fight yet.
But why not just have the existing kfree_rcu() API cover both kmalloc()
and kvmalloc()? Perhaps I am not in the right forums, but I am not hearing
anyone arguing that the RCU API has too few members. ;-)
Thanx, Paul
Powered by blists - more mailing lists