[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20180207120949.62fa815f@gandalf.local.home>
Date: Wed, 7 Feb 2018 12:09:49 -0500
From: Steven Rostedt <rostedt@...dmis.org>
To: Christopher Lameter <cl@...ux.com>
Cc: Matthew Wilcox <willy@...radead.org>,
"Paul E. McKenney" <paulmck@...ux.vnet.ibm.com>,
Kirill Tkhai <ktkhai@...tuozzo.com>, josh@...htriplett.org,
mathieu.desnoyers@...icios.com, jiangshanlai@...il.com,
mingo@...hat.com, penberg@...nel.org, rientjes@...gle.com,
iamjoonsoo.kim@....com, akpm@...ux-foundation.org,
linux-kernel@...r.kernel.org, linux-mm@...ck.org,
brouer@...hat.com, rao.shoaib@...cle.com
Subject: Re: [PATCH 0/2] rcu: Transform kfree_rcu() into kvfree_rcu()
On Wed, 7 Feb 2018 10:47:02 -0600 (CST)
Christopher Lameter <cl@...ux.com> wrote:
> On Tue, 6 Feb 2018, Matthew Wilcox wrote:
>
> > Personally, I would like us to rename kvfree() to just free(), and have
> > malloc(x) be an alias to kvmalloc(x, GFP_KERNEL), but I haven't won that
> > fight yet.
>
> Maybe lets implement malloc(), free() and realloc() in the kernel to be
> consistent with user space use as possible? Only use the others
> allocation variants for special cases.
They would need to drop the GFP part and default to GFP_KERNEL.
>
> So malloc would check allocation sizes and if < 2* PAGE_SIZE use kmalloc()
> otherwise vmalloc().
Please no, I hate subtle internal decisions like this. It makes
debugging much more difficult, when allocating dynamic sized variables.
When something works at one size but not the other.
-- Steve
>
> free() would free anything you give it.
Powered by blists - more mailing lists