lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Tue, 13 Feb 2018 10:31:18 +0100
From:   Ingo Molnar <mingo@...nel.org>
To:     Peter Zijlstra <peterz@...radead.org>
Cc:     Vincent Guittot <vincent.guittot@...aro.org>,
        linux-kernel@...r.kernel.org
Subject: Re: [PATCH] sched: typo: remove space in #ifdef


* Peter Zijlstra <peterz@...radead.org> wrote:

> On Tue, Feb 13, 2018 at 09:59:42AM +0100, Vincent Guittot wrote:
> > Remove a useless space in # ifdef and align it with others
> > 
> > Signed-off-by: Vincent Guittot <vincent.guittot@...aro.org>
> > ---
> >  kernel/sched/fair.c | 4 ++--
> >  1 file changed, 2 insertions(+), 2 deletions(-)
> > 
> > diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
> > index 1070803..cad1932 100644
> > --- a/kernel/sched/fair.c
> > +++ b/kernel/sched/fair.c
> > @@ -2823,7 +2823,7 @@ void reweight_task(struct task_struct *p, int prio)
> >  }
> >  
> >  #ifdef CONFIG_FAIR_GROUP_SCHED
> > -# ifdef CONFIG_SMP
> > +#ifdef CONFIG_SMP
> 
> Heh, so this is one where Ingo and me disagree ;-)

In this particular case I agree with you.

> He likes that indented preprocessor nonsense, whereas I just find it really 
> bothersome.

Here it's bothersome, because the #ifdef block is long.

It's actually a big improvement in other places:

#ifdef CONFIG_EFI_STUB
# ifdef CONFIG_EFI_MIXED
#  define XLF23 (XLF_EFI_HANDOVER_32|XLF_EFI_HANDOVER_64)
# else
#  ifdef CONFIG_X86_64
#   define XLF23 XLF_EFI_HANDOVER_64            /* 64-bit EFI handover ok */
#  else
#   define XLF23 XLF_EFI_HANDOVER_32            /* 32-bit EFI handover ok */
#  endif
# endif
#else
# define XLF23 0
#endif

Which is a _LOT_ more structured and easier to read than:

#ifdef CONFIG_EFI_STUB
#ifdef CONFIG_EFI_MIXED
#define XLF23 (XLF_EFI_HANDOVER_32|XLF_EFI_HANDOVER_64)
#else
#ifdef CONFIG_X86_64
#define XLF23 XLF_EFI_HANDOVER_64            /* 64-bit EFI handover ok */
#else
#define XLF23 XLF_EFI_HANDOVER_32            /* 32-bit EFI handover ok */
#endif
#endif
#else
#define XLF23 0
#endif

Thanks,

	Ingo

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ