[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20180222183403.GA6267@infradead.org>
Date: Thu, 22 Feb 2018 10:34:03 -0800
From: Christoph Hellwig <hch@...radead.org>
To: Oza Pawandeep <poza@...eaurora.org>
Cc: Bjorn Helgaas <bhelgaas@...gle.com>,
Philippe Ombredanne <pombredanne@...b.com>,
Thomas Gleixner <tglx@...utronix.de>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Kate Stewart <kstewart@...uxfoundation.org>,
linux-pci@...r.kernel.org, linux-kernel@...r.kernel.org,
Dongdong Liu <liudongdong3@...wei.com>,
Keith Busch <keith.busch@...el.com>, Wei Zhang <wzhang@...com>,
Sinan Kaya <okaya@...eaurora.org>,
Timur Tabi <timur@...eaurora.org>
Subject: Re: [PATCH v10 1/7] PCI/AER: Rename error recovery to generic pci
naming
On Thu, Feb 22, 2018 at 09:32:06PM +0530, Oza Pawandeep wrote:
> This patch renames error recovery to generic name with pci prefix
>
> Signed-off-by: Oza Pawandeep <poza@...eaurora.org>
>
> diff --git a/drivers/pci/pcie/aer/aerdrv_core.c b/drivers/pci/pcie/aer/aerdrv_core.c
> index a4bfea5..306bf2f 100644
> --- a/drivers/pci/pcie/aer/aerdrv_core.c
> +++ b/drivers/pci/pcie/aer/aerdrv_core.c
> @@ -478,7 +478,7 @@ static pci_ers_result_t reset_link(struct pci_dev *dev)
> }
>
> /**
> - * do_recovery - handle nonfatal/fatal error recovery process
> + * pci_do_recovery - handle nonfatal/fatal error recovery process
> * @dev: pointer to a pci_dev data structure of agent detecting an error
> * @severity: error severity type
> *
> @@ -486,7 +486,7 @@ static pci_ers_result_t reset_link(struct pci_dev *dev)
> * error detected message to all downstream drivers within a hierarchy in
> * question and return the returned code.
> */
> -static void do_recovery(struct pci_dev *dev, int severity)
> +static void pci_do_recovery(struct pci_dev *dev, int severity)
Maybe pcie_do_recovery?
Otherwise looks fine:
Reviewed-by: Christoph Hellwig <hch@....de>
Powered by blists - more mailing lists