[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <cb405817-0bc5-fdea-baa7-e11e4a7a4163@redhat.com>
Date: Sat, 24 Feb 2018 00:38:21 +0100
From: Paolo Bonzini <pbonzini@...hat.com>
To: Tom Lendacky <thomas.lendacky@....com>, x86@...nel.org,
linux-kernel@...r.kernel.org, kvm@...r.kernel.org
Cc: Joerg Roedel <joro@...tes.org>, Borislav Petkov <bp@...en8.de>,
Thomas Gleixner <tglx@...utronix.de>,
Radim Krčmář <rkrcmar@...hat.com>
Subject: Re: [PATCH v3 0/2] KVM: MSR-based features
On 21/02/2018 20:39, Tom Lendacky wrote:
> The following series implements support within KVM for MSR-based features.
> The first patch creates the MSR-based feature framework used to retrieve
> the available MSR-based features. The second patch makes use of the
> framework to allow a guest to determine if the LFENCE instruction is
> serializing on AMD processors.
>
> This series is based on the master branch of the KVM git tree.
>
> https://git.kernel.org/pub/scm/virt/kvm/kvm.git
I made a couple adjustments:
- use a system (/dev/kvm) ioctl, which unfortunately means a new ioctl
#define but is more consistent with KVM_GET_SUPPORTED_CPUID and
KVM_GET_MSR_INDEX_LIST
- rename msr_feature to get_msr_feature
Please take a look at kvm/queue! Thanks,
Paolo
> ---
>
> Changes from v2:
> - Moved back to initializing the MSR-based feature list in kvm_init_msr_list()
> (based on the kvm_x86_ops callback return code)
> - Removed the definition of KVM_GET_MSR and switched back to using KVM_GET_MSRS
> - Consolidated the documentation to group the ioctl usage and describe the usage
> specific to the version of the ioctl used.
>
> Tom Lendacky (2):
> KVM: x86: Add a framework for supporting MSR-based features
> KVM: SVM: Add MSR-based feature support for serializing LFENCE
>
>
> Documentation/virtual/kvm/api.txt | 29 +++++++++++----
> arch/x86/include/asm/kvm_host.h | 2 +
> arch/x86/kvm/svm.c | 43 ++++++++++++++++++++++
> arch/x86/kvm/x86.c | 72 +++++++++++++++++++++++++++++++++++--
> include/uapi/linux/kvm.h | 1 +
> 5 files changed, 136 insertions(+), 11 deletions(-)
>
Powered by blists - more mailing lists