[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <603d5335-6220-73f2-d902-b92bc74bc79e@c-s.fr>
Date: Tue, 27 Feb 2018 08:33:19 +0100
From: Christophe LEROY <christophe.leroy@....fr>
To: Mathieu Malaterre <malat@...ian.org>,
Andy Shevchenko <andy.shevchenko@...il.com>
Cc: Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Paul Mackerras <paulus@...ba.org>,
Jiri Slaby <jslaby@...e.com>,
"open list:LINUX FOR POWERPC PA SEMI PWRFICIENT"
<linuxppc-dev@...ts.ozlabs.org>
Subject: Re: [PATCH 01/21] powerpc: Remove warning on array size when empty
Le 27/02/2018 à 08:25, Mathieu Malaterre a écrit :
> On Mon, Feb 26, 2018 at 3:45 PM, Andy Shevchenko
> <andy.shevchenko@...il.com> wrote:
>> On Mon, Feb 26, 2018 at 4:44 PM, Andy Shevchenko
>> <andy.shevchenko@...il.com> wrote:
>>> On Sun, Feb 25, 2018 at 7:22 PM, Mathieu Malaterre <malat@...ian.org> wrote:
>>
>>>> static void __init check_cpu_feature_properties(unsigned long node)
>>>> {
>>>> - unsigned long i;
>>>> struct feature_property *fp = feature_properties;
>>>> const __be32 *prop;
>>>>
>>>
>>> Much simpler is just add
>>>
>>> if (ARRAY_SIZE() == 0)
>>> return;
>>>
>>>> - for (i = 0; i < ARRAY_SIZE(feature_properties); ++i, ++fp) {
>>>> + for (; fp != feature_properties + ARRAY_SIZE(feature_properties); ++fp) {
>>
>> ...or convert to while(), which will be more readable.
>
> So you'd prefer something like:
>
> while (fp < feature_properties + ARRAY_SIZE(feature_properties)) {
> ...
> ++fp;
> }
>
> right ?
>
Why not do as suggested by Segher, ie just replace < by != in the
original form ?
Or add in front:
if (!ARRAY_SIZE(feature_properties))
return;
Christophe
Powered by blists - more mailing lists