[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20180228120929.GB63063@linux.vnet.ibm.com>
Date: Wed, 28 Feb 2018 04:09:29 -0800
From: Srikar Dronamraju <srikar@...ux.vnet.ibm.com>
To: Ravi Bangoria <ravi.bangoria@...ux.vnet.ibm.com>
Cc: peterz@...radead.org, mingo@...hat.com, acme@...nel.org,
alexander.shishkin@...ux.intel.com, jolsa@...hat.com,
namhyung@...nel.org, linux-kernel@...r.kernel.org,
rostedt@...dmis.org, mhiramat@...nel.org,
ananth@...ux.vnet.ibm.com, naveen.n.rao@...ux.vnet.ibm.com,
oleg@...hat.com
Subject: Re: [RFC 1/4] Uprobe: Rename map_info to uprobe_map_info
>
> -static inline struct map_info *free_map_info(struct map_info *info)
> +static inline struct uprobe_map_info *
> +free_uprobe_map_info(struct uprobe_map_info *info)
> {
> - struct map_info *next = info->next;
> + struct uprobe_map_info *next = info->next;
> kfree(info);
> return next;
> }
>
> -static struct map_info *
> -build_map_info(struct address_space *mapping, loff_t offset, bool is_register)
> +static struct uprobe_map_info *
> +build_uprobe_map_info(struct address_space *mapping, loff_t offset,
> + bool is_register)
Imho, uprobe_build_map_info may be better than build_uprobe_map_info,
similarly uprobe_free_map_info.
Powered by blists - more mailing lists