[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <5A9FC3E0.5020600@rock-chips.com>
Date: Wed, 07 Mar 2018 18:50:08 +0800
From: JeffyChen <jeffy.chen@...k-chips.com>
To: Mark Brown <broonie@...nel.org>
CC: linux-kernel@...r.kernel.org, Arnd Bergmann <arnd@...db.de>,
Lee Jones <lee.jones@...aro.org>
Subject: Re: [PATCH v2 1/3] mfd: syscon: Set name of regmap_config
Hi Mark,
On 03/07/2018 06:20 PM, Mark Brown wrote:
> On Tue, Mar 06, 2018 at 10:58:26PM +0800, JeffyChen wrote:
>
>> even this is already fixed by a430ab205d29 ("regmap: debugfs: Disambiguate
>> dummy debugfs file name")
>
>> but maybe we can still have this for a better debugfs name?
>
> That's why the facility is there.
>
> Please don't top post, reply in line with needed context. This allows
> readers to readily follow the flow of conversation and understand what
> you are talking about and also helps ensure that everything in the
> discussion is being addressed.
>
ok, sorry for that :)
recently we are now allowing to register debugfs for syscon regmap, then
i hit a lot of:
(NULL device *): Failed to create debugfs directory
so i sent this patch to fix that by using the of_node name to create
debugfs.
but later i found we have:
commit a430ab205d29e7d1537b220fcf989b8080d8267f
Author: Fabio Estevam <fabio.estevam@....com>
Date: Mon Mar 5 15:52:09 2018 -0300
regmap: debugfs: Disambiguate dummy debugfs file name
which would fix that in another way by naming dummy0, dummy1, dummy2.
even if the issue is fixed, i wonder could we still have this patch to
make it more readable:
+++ b/drivers/mfd/syscon.c
@@ -109,6 +109,7 @@ static struct syscon *of_syscon_register(struct
device_node *np)
syscon_config.reg_stride = reg_io_width;
syscon_config.val_bits = reg_io_width * 8;
syscon_config.max_register = resource_size(&res) - reg_io_width;
+ syscon_config.name = of_node_full_name(np);
and i've sent 2 more patches to fix the memleak there:
https://patchwork.kernel.org/patch/10261409
https://patchwork.kernel.org/patch/10261411
and sorry again, i forgot to add a cover letter, and i should CC you the
whole series.
Powered by blists - more mailing lists