[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <56e72cd2-9730-f031-ae75-915b94103588@nvidia.com>
Date: Mon, 19 Mar 2018 16:09:08 -0700
From: John Hubbard <jhubbard@...dia.com>
To: <jglisse@...hat.com>, <linux-mm@...ck.org>
CC: Andrew Morton <akpm@...ux-foundation.org>,
<linux-kernel@...r.kernel.org>,
Evgeny Baskakov <ebaskakov@...dia.com>,
Ralph Campbell <rcampbell@...dia.com>,
Mark Hairgrove <mhairgrove@...dia.com>
Subject: Re: [PATCH 10/14] mm/hmm: rename HMM_PFN_DEVICE_UNADDRESSABLE to
HMM_PFN_DEVICE_PRIVATE
On 03/16/2018 01:35 PM, jglisse@...hat.com wrote:
> From: Jérôme Glisse <jglisse@...hat.com>
>
> Make naming consistent accross code, DEVICE_PRIVATE is the name use
> outside HMM code so use that one.
>
> Signed-off-by: Jérôme Glisse <jglisse@...hat.com>
> Cc: Evgeny Baskakov <ebaskakov@...dia.com>
> Cc: Ralph Campbell <rcampbell@...dia.com>
> Cc: Mark Hairgrove <mhairgrove@...dia.com>
> Cc: John Hubbard <jhubbard@...dia.com>
> ---
> include/linux/hmm.h | 4 ++--
> mm/hmm.c | 2 +-
> 2 files changed, 3 insertions(+), 3 deletions(-)
Seems entirely harmless. :)
Reviewed-by: John Hubbard <jhubbard@...dia.com>
>
> diff --git a/include/linux/hmm.h b/include/linux/hmm.h
> index 6d2b6bf6da4b..78018b3e7a9f 100644
> --- a/include/linux/hmm.h
> +++ b/include/linux/hmm.h
> @@ -88,13 +88,13 @@ struct hmm;
> * result of vm_insert_pfn() or vm_insert_page(). Therefore, it should not
> * be mirrored by a device, because the entry will never have HMM_PFN_VALID
> * set and the pfn value is undefined.
> - * HMM_PFN_DEVICE_UNADDRESSABLE: unaddressable device memory (ZONE_DEVICE)
> + * HMM_PFN_DEVICE_PRIVATE: unaddressable device memory (ZONE_DEVICE)
> */
> #define HMM_PFN_VALID (1 << 0)
> #define HMM_PFN_WRITE (1 << 1)
> #define HMM_PFN_ERROR (1 << 2)
> #define HMM_PFN_SPECIAL (1 << 3)
> -#define HMM_PFN_DEVICE_UNADDRESSABLE (1 << 4)
> +#define HMM_PFN_DEVICE_PRIVATE (1 << 4)
> #define HMM_PFN_SHIFT 5
>
> /*
> diff --git a/mm/hmm.c b/mm/hmm.c
> index 2118e42cb838..857eec622c98 100644
> --- a/mm/hmm.c
> +++ b/mm/hmm.c
> @@ -429,7 +429,7 @@ static int hmm_vma_walk_pmd(pmd_t *pmdp,
> pfns[i] |= HMM_PFN_WRITE;
> } else if (write_fault)
> goto fault;
> - pfns[i] |= HMM_PFN_DEVICE_UNADDRESSABLE;
> + pfns[i] |= HMM_PFN_DEVICE_PRIVATE;
> } else if (is_migration_entry(entry)) {
> if (hmm_vma_walk->fault) {
> pte_unmap(ptep);
>
thanks,
--
John Hubbard
NVIDIA
Powered by blists - more mailing lists