[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <ec252c56d4e56b769a57e4a91ddd9dfdd440d641.1525072600.git.greentime@andestech.com>
Date: Mon, 30 Apr 2018 15:20:40 +0800
From: Greentime Hu <green.hu@...il.com>
To: linux-kernel@...r.kernel.org, arnd@...db.de,
greentime@...estech.com, green.hu@...il.com
Subject: [PATCH 2/3] nds32: To refine readability of INT_MASK_INITAIAL_VAL
Refine readability of INT_MASK_INITAIAL_VAL with meaningful macro instead
of magic number.
Signed-off-by: Greentime Hu <greentime@...estech.com>
---
arch/nds32/include/asm/bitfield.h | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/nds32/include/asm/bitfield.h b/arch/nds32/include/asm/bitfield.h
index c73f71d67744..28b7d797fd59 100644
--- a/arch/nds32/include/asm/bitfield.h
+++ b/arch/nds32/include/asm/bitfield.h
@@ -336,7 +336,7 @@
#define INT_MASK_mskIDIVZE ( 0x1 << INT_MASK_offIDIVZE )
#define INT_MASK_mskDSSIM ( 0x1 << INT_MASK_offDSSIM )
-#define INT_MASK_INITAIAL_VAL 0x10003
+#define INT_MASK_INITAIAL_VAL (INT_MASK_mskDSSIM|INT_MASK_mskIDIVZE)
/******************************************************************************
* ir15: INT_PEND (Interrupt Pending Register)
--
1.9.5
Powered by blists - more mailing lists