[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20180503234409.GY27853@wotan.suse.de>
Date: Thu, 3 May 2018 23:44:09 +0000
From: "Luis R. Rodriguez" <mcgrof@...nel.org>
To: Andres Rodriguez <andresx7@...il.com>
Cc: linux-kernel@...r.kernel.org, gregkh@...uxfoundation.org,
mcgrof@...nel.org, alexdeucher@...il.com, christian.koenig@....com,
kvalo@...eaurora.org, arend.vanspriel@...adcom.com,
linux-wireless@...r.kernel.org, ath10k@...ts.infradead.org,
hdegoede@...hat.com, Kees Cook <keescook@...omium.org>
Subject: Re: [PATCH 7/9] firmware: use rename fw_sysfs_fallback to use the
firmware_ prefix
On Mon, Apr 23, 2018 at 04:12:03PM -0400, Andres Rodriguez wrote:
> Use the correct prefix for symbols exported by firmware_loader(). This
> is done since firmware_sysfs_fallback() is now exposed through
> kernel-doc.
>
> Signed-off-by: Andres Rodriguez <andresx7@...il.com>
> ---
> drivers/base/firmware_loader/fallback.c | 8 ++++----
> drivers/base/firmware_loader/fallback.h | 4 ++--
> drivers/base/firmware_loader/firmware.h | 6 +++---
> drivers/base/firmware_loader/main.c | 2 +-
> 4 files changed, 10 insertions(+), 10 deletions(-)
>
> diff --git a/drivers/base/firmware_loader/fallback.c b/drivers/base/firmware_loader/fallback.c
> index 1a47ddc70c31..fc186b5bccce 100644
> --- a/drivers/base/firmware_loader/fallback.c
> +++ b/drivers/base/firmware_loader/fallback.c
> @@ -661,10 +661,10 @@ static bool fw_run_sysfs_fallback(enum fw_opt opt_flags)
> return fw_force_sysfs_fallback(opt_flags);
> }
>
> -int fw_sysfs_fallback(struct firmware *fw, const char *name,
> - struct device *device,
> - enum fw_opt opt_flags,
> - int ret)
> +int firmware_sysfs_fallback(struct firmware *fw, const char *name,
> + struct device *device,
> + enum fw_opt opt_flags,
> + int ret)
Since we may get more than one fallback later I'll usee the firmware_fallback_sysfs() here.
I'll do this change and resubmit myself.
> {
> if (!fw_run_sysfs_fallback(opt_flags))
> return ret;
> diff --git a/drivers/base/firmware_loader/fallback.h b/drivers/base/firmware_loader/fallback.h
> index a3b73a09db6c..8cfaa3299bb7 100644
> --- a/drivers/base/firmware_loader/fallback.h
> +++ b/drivers/base/firmware_loader/fallback.h
> @@ -31,7 +31,7 @@ struct firmware_fallback_config {
> };
>
> #ifdef CONFIG_FW_LOADER_USER_HELPER
> -int fw_sysfs_fallback(struct firmware *fw, const char *name,
> +int firmware_sysfs_fallback(struct firmware *fw, const char *name,
> struct device *device,
> enum fw_opt opt_flags,
> int ret);
> @@ -43,7 +43,7 @@ void fw_fallback_set_default_timeout(void);
> int register_sysfs_loader(void);
> void unregister_sysfs_loader(void);
> #else /* CONFIG_FW_LOADER_USER_HELPER */
> -static inline int fw_sysfs_fallback(struct firmware *fw, const char *name,
> +static inline int firmware_sysfs_fallback(struct firmware *fw, const char *name,
> struct device *device,
> enum fw_opt opt_flags,
> int ret)
> diff --git a/drivers/base/firmware_loader/firmware.h b/drivers/base/firmware_loader/firmware.h
> index a405d400a925..59836d50c5bd 100644
> --- a/drivers/base/firmware_loader/firmware.h
> +++ b/drivers/base/firmware_loader/firmware.h
> @@ -15,12 +15,12 @@
> * enum fw_opt - options to control firmware loading behaviour
> *
> * @FW_OPT_UEVENT: Enables the fallback mechanism to send a kobject uevent
> - * when the firmware is not found. Userspace is in charge
> - * to load the firmware using the sysfs loading facility.
> + * when the firmware is not found. Userspace is in charge
> + * to load the firmware using the sysfs loading facility.
This change was really not part of this patch, so I'll merge it in with the
other patch.
> * @FW_OPT_NOWAIT: Used to describe the firmware request is asynchronous.
> * @FW_OPT_USERHELPER: Enable the fallback mechanism, in case the direct
> * filesystem lookup fails at finding the firmware.
> - * For details refer to fw_sysfs_fallback().
> + * For details refer to firmware_sysfs_fallback().
> * @FW_OPT_NO_WARN: Quiet, avoid printing warning messages.
> * @FW_OPT_NOCACHE: Disables firmware caching. Firmware caching is used to
> * cache the firmware upon suspend, so that upon resume
> diff --git a/drivers/base/firmware_loader/main.c b/drivers/base/firmware_loader/main.c
> index 58aaadf81e12..f009566acd35 100644
> --- a/drivers/base/firmware_loader/main.c
> +++ b/drivers/base/firmware_loader/main.c
> @@ -581,7 +581,7 @@ _firmware_request(const struct firmware **firmware_p, const char *name,
> dev_warn(device,
> "Direct firmware load for %s failed with error %d\n",
> name, ret);
> - ret = fw_sysfs_fallback(fw, name, device, opt_flags, ret);
> + ret = firmware_sysfs_fallback(fw, name, device, opt_flags, ret);
> } else
> ret = assign_fw(fw, device, opt_flags);
>
> --
> 2.14.1
>
>
--
Do not panic
Powered by blists - more mailing lists