[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20180507063224.24229-1-bhe@redhat.com>
Date: Mon, 7 May 2018 14:32:21 +0800
From: Baoquan He <bhe@...hat.com>
To: linux-kernel@...r.kernel.org, akpm@...ux-foundation.org,
robh+dt@...nel.org, dan.j.williams@...el.com,
nicolas.pitre@...aro.org, josh@...htriplett.org,
fengguang.wu@...el.com, bp@...e.de
Cc: patrik.r.jakobsson@...il.com, airlied@...ux.ie, kys@...rosoft.com,
haiyangz@...rosoft.com, sthemmin@...rosoft.com,
dmitry.torokhov@...il.com, frowand.list@...il.com,
keith.busch@...el.com, jonathan.derrick@...el.com,
lorenzo.pieralisi@....com, bhelgaas@...gle.com, tglx@...utronix.de,
brijesh.singh@....com, jglisse@...hat.com, thomas.lendacky@....com,
gregkh@...uxfoundation.org, baiyaowei@...s.chinamobile.com,
richard.weiyang@...il.com, devel@...uxdriverproject.org,
linux-input@...r.kernel.org, linux-nvdimm@...ts.01.org,
devicetree@...r.kernel.org, linux-pci@...r.kernel.org,
ebiederm@...ssion.com, vgoyal@...hat.com, dyoung@...hat.com,
yinghai@...nel.org, kexec@...ts.infradead.org, monstr@...str.eu,
davem@...emloft.net, chris@...kel.net, jcmvbkbc@...il.com,
gustavo@...ovan.org, maarten.lankhorst@...ux.intel.com,
seanpaul@...omium.org, linux-parisc@...r.kernel.org,
Baoquan He <bhe@...hat.com>
Subject: [PATCH v4 0/3] resource: Use list_head to link sibling resource
This patchset is doing:
1) Replace struct resource's sibling list from singly linked list to
list_head. Clearing out those pointer operation within singly linked
list for better code readability.
2) Based on list_head replacement, add a new function
walk_system_ram_res_rev() which can does reversed iteration on
iomem_resource's siblings.
3) Change kexec_file loading to search system RAM top down for kernel
loadin, using walk_system_ram_res_rev().
Note:
This patchset passed testing on my kvm guest, x86_64 arch with network
enabling. The thing we need pay attetion to is that a root resource's
child member need be initialized specifically with LIST_HEAD_INIT() if
statically defined or INIT_LIST_HEAD() for dynamically definition. Here
Just like we do for iomem_resource/ioport_resource, or the change in
get_pci_domain_busn_res().
Links of the old posting(Boris pointed out that we should use
https://lkml.kernel.org/r/Message-ID, while it can't be opened from
my side, so paste all of them here.):
v3:
https://lkml.kernel.org/r/20180419001848.3041-1-bhe@redhat.com
https://lkml.org/lkml/2018/4/18/767
v2:
https://lkml.kernel.org/r/20180408024724.16812-1-bhe@redhat.com
https://lkml.org/lkml/2018/4/7/169
v1:
https://lkml.kernel.org/r/20180322033722.9279-1-bhe@redhat.com
https://lkml.org/lkml/2018/3/21/952
Changelog:
v3->v4:
Fix several bugs test robot reported. Rewrite cover letter and patch
log according to reviewer's comment.
v2->v3:
Rename resource functions first_child() and sibling() to
resource_first_chils() and resource_sibling(). Dan suggested this.
Move resource_first_chils() and resource_sibling() to linux/ioport.h
and make them as inline function. Rob suggested this. Accordingly add
linux/list.h including in linux/ioport.h, please help review if this
bring efficiency degradation or code redundancy.
The change on struct resource {} bring two pointers of size increase,
mention this in git log to make it more specifically, Rob suggested
this.
v1->v2:
Use list_head instead to link resource siblings. This is suggested by
Andrew.
Rewrite walk_system_ram_res_rev() after list_head is taken to link
resouce siblings.
Baoquan He (3):
resource: Use list_head to link sibling resource
resource: add walk_system_ram_res_rev()
kexec_file: Load kernel at top of system RAM if required
arch/microblaze/pci/pci-common.c | 31 ++--
arch/sparc/kernel/ioport.c | 2 +-
arch/xtensa/include/asm/pci-bridge.h | 4 +-
drivers/eisa/eisa-bus.c | 2 +
drivers/gpu/drm/drm_memory.c | 3 +-
drivers/gpu/drm/gma500/gtt.c | 5 +-
drivers/hv/vmbus_drv.c | 52 +++----
drivers/input/joystick/iforce/iforce-main.c | 4 +-
drivers/nvdimm/e820.c | 2 +-
drivers/nvdimm/namespace_devs.c | 6 +-
drivers/nvdimm/nd.h | 5 +-
drivers/of/address.c | 4 +-
drivers/parisc/lba_pci.c | 4 +-
drivers/pci/host/vmd.c | 8 +-
drivers/pci/probe.c | 2 +
drivers/pci/setup-bus.c | 2 +-
include/linux/ioport.h | 20 ++-
kernel/kexec_file.c | 2 +
kernel/resource.c | 221 ++++++++++++++++------------
19 files changed, 215 insertions(+), 164 deletions(-)
--
2.13.6
Powered by blists - more mailing lists