[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20180508114500.qrtnjax4siupgv3n@mwanda>
Date: Tue, 8 May 2018 14:45:00 +0300
From: Dan Carpenter <dan.carpenter@...cle.com>
To: James Simmons <jsimmons@...radead.org>
Cc: Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
devel@...verdev.osuosl.org,
Andreas Dilger <andreas.dilger@...el.com>,
Oleg Drokin <oleg.drokin@...el.com>,
Lai Siyao <lai.siyao@...el.com>,
Jinshan Xiong <jinshan.xiong@...el.com>,
NeilBrown <neilb@...e.com>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
Lustre Development List <lustre-devel@...ts.lustre.org>
Subject: Re: [PATCH 4/4] staging: lustre: obdclass: change object lookup to
no wait mode
> /*
> * Allocate new object. This may result in rather complicated
> * operations, including fld queries, inode loading, etc.
> */
> o = lu_object_alloc(env, dev, f, conf);
> - if (IS_ERR(o))
> + if (unlikely(IS_ERR(o)))
> return o;
>
This is an unrelated and totally pointless. likely/unlikely annotations
hurt readability, and they should only be added if it's something which
is going to show up in benchmarking. lu_object_alloc() is already too
slow for the unlikely() to make a difference and anyway IS_ERR() has an
unlikely built in so it's duplicative...
Anyway, I understand that Intel has been ignoring kernel.org instead of
sending forwarding their patches properly so you're doing a difficult
and thankless job... Thanks for that. I'm sure it's frustrating to
look at these patches for you as well.
regards,
dan carpenter
Powered by blists - more mailing lists