[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20180518160512.GG22791@infradead.org>
Date: Fri, 18 May 2018 09:05:12 -0700
From: Christoph Hellwig <hch@...radead.org>
To: adam.manzanares@....com
Cc: viro@...iv.linux.org.uk, linux-fsdevel@...r.kernel.org,
axboe@...nel.dk, bcrl@...ck.org, mingo@...nel.org,
peterz@...radead.org, pombredanne@...b.com,
gregkh@...uxfoundation.org, bigeasy@...utronix.de,
rgoldwyn@...e.com, linux-block@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-aio@...ck.org,
linux-api@...r.kernel.org
Subject: Re: [PATCH v4 2/3] fs: Convert kiocb rw_hint from enum to u16
> +/* ki_hint changed from enum to u16, make sure rw_hint fits into u16 */
I don't think this comment is very useful.
> +static inline u16 ki_hint_valid(enum rw_hint hint)
I'd call this ki_hint_validate.
> +{
> + if (hint > MAX_KI_HINT)
> + return 0;
> +
> + return hint;
Nit: kill the empty line.
Powered by blists - more mailing lists