[<prev] [next>] [day] [month] [year] [list]
Message-Id: <67F0DCCC-BBC5-4B7B-9FC4-1BD83D247DAA@iauto.com>
Date: Thu, 31 May 2018 11:15:12 +0800
From: kuangrufan@...to.com
To: Todd Kjos <tkjos@...gle.com>
Cc: LKML <linux-kernel@...r.kernel.org>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Arve Hjønnevåg <arve@...roid.com>,
Todd Kjos <tkjos@...roid.com>,
Martijn Coenen <maco@...roid.com>,
"open list:ANDROID DRIVERS" <devel@...verdev.osuosl.org>
Subject: Re: [PATCH] ANDROID: binder: rename parameter to resolve name
collision.
> Why is this needed? These don't collide in the namespace:
Sorry, I check it again, you’re right. my bad.
PS:
I need to change the binder API between 32bit & 64bit dynamically.
So I was trying to compile binder as a “.ko”. I compiled the 2
files into the same kernel module, which causes problem.
Best Regards,
> 在 2018年5月30日,下午11:54,Todd Kjos <tkjos@...gle.com> 写道:
>
> Why is this needed? These don't collide in the namespace:
>
> /sys/module/binder/parameters/debug_mask
>
> and
>
> /sys/module/binder_alloc/parameters/debug_mask.
>
> On Tue, May 29, 2018 at 9:58 PM <kuangrufan@...to.com> wrote:
> From: Kuang Rufan <kuangrufan@...to.com>
>
> both bind.c & binder_alloc.c define the same kernel parameter 'debug_mask',
> rename the one in binder_alloc.c to 'alloc_debug_mask'.
>
> Signed-off-by: Kuang Rufan <kuangrufan@...to.com>
> ---
> drivers/android/binder_alloc.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/android/binder_alloc.c b/drivers/android/binder_alloc.c
> index 5a426c877dfb..3850dab493d4 100644
> --- a/drivers/android/binder_alloc.c
> +++ b/drivers/android/binder_alloc.c
> @@ -42,7 +42,7 @@ enum {
> };
> static uint32_t binder_alloc_debug_mask;
>
> -module_param_named(debug_mask, binder_alloc_debug_mask,
> +module_param_named(alloc_debug_mask, binder_alloc_debug_mask,
> uint, 0644);
>
> #define binder_alloc_debug(mask, x...) \
> --
> 2.15.1 (Apple Git-101)
>
Powered by blists - more mailing lists