[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <91e35b3e-b42d-b3d5-752c-031973e69273@intel.com>
Date: Fri, 8 Jun 2018 11:34:29 -0700
From: Dave Hansen <dave.hansen@...el.com>
To: Jarkko Sakkinen <jarkko.sakkinen@...ux.intel.com>, x86@...nel.org,
platform-driver-x86@...r.kernel.org
Cc: sean.j.christopherson@...el.com, nhorman@...hat.com,
npmccallum@...hat.com, Darren Hart <dvhart@...radead.org>,
Andy Shevchenko <andy@...radead.org>,
"open list:INTEL SGX" <intel-sgx-kernel-dev@...ts.01.org>,
open list <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH v11 11/13] intel_sgx: ptrace() support
On 06/08/2018 10:09 AM, Jarkko Sakkinen wrote:
> + ret = sgx_edbgrd(encl, entry, align, data);
> + if (ret)
> + break;
> + if (write) {
> + memcpy(data + offset, buf + i, cnt);
> + ret = sgx_edbgwr(encl, entry, align, data);
> + if (ret)
> + break;
> + }
> + else
> + memcpy(buf + i,data + offset, cnt);
> + }
The SGX instructions like "edbgrd" be great to put on a license plat,
but we can do better in the kernel. Can you give these reasonable
english names, please? sgx_debug_write(), maybe?
Note that we have plenty of incomprehensible instruction names in the
kernel like "wrpkru", but we do our best to keep them as confined as
possible and make sure they don't hurt code readability.
Powered by blists - more mailing lists