[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20180611181935.155032-1-briannorris@chromium.org>
Date: Mon, 11 Jun 2018 11:19:35 -0700
From: Brian Norris <briannorris@...omium.org>
To: Kalle Valo <kvalo@....qualcomm.com>
Cc: ath10k@...ts.infradead.org, linux-wireless@...r.kernel.org,
<linux-kernel@...r.kernel.org>,
Brian Norris <briannorris@...omium.org>
Subject: [PATCH] ath10k: use crash_dump enum instead of magic numbers
The comments are telling you what the enum could tell you instead.
Signed-off-by: Brian Norris <briannorris@...omium.org>
---
drivers/net/wireless/ath/ath10k/core.c | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/net/wireless/ath/ath10k/core.c b/drivers/net/wireless/ath/ath10k/core.c
index 4cf54a7ef09a..eae46a04f503 100644
--- a/drivers/net/wireless/ath/ath10k/core.c
+++ b/drivers/net/wireless/ath/ath10k/core.c
@@ -41,10 +41,8 @@ static bool uart_print;
static bool skip_otp;
static bool rawmode;
-/* Enable ATH10K_FW_CRASH_DUMP_REGISTERS and ATH10K_FW_CRASH_DUMP_CE_DATA
- * by default.
- */
-unsigned long ath10k_coredump_mask = 0x3;
+unsigned long ath10k_coredump_mask = BIT(ATH10K_FW_CRASH_DUMP_REGISTERS) |
+ BIT(ATH10K_FW_CRASH_DUMP_CE_DATA);
/* FIXME: most of these should be readonly */
module_param_named(debug_mask, ath10k_debug_mask, uint, 0644);
--
2.18.0.rc1.242.g61856ae69a-goog
Powered by blists - more mailing lists