lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 18 Jun 2018 10:42:59 +0200
From:   Enric Balletbo Serra <eballetbo@...il.com>
To:     Lee Jones <lee.jones@...aro.org>
Cc:     Enric Balletbo i Serra <enric.balletbo@...labora.com>,
        linux-kernel <linux-kernel@...r.kernel.org>,
        Gwendal Grignou <gwendal@...omium.org>, kernel@...labora.com,
        Dmitry Torokhov <dmitry.torokhov@...il.com>
Subject: Re: [PATCH v3 03/12] mfd: cros_ec: Make license text and module
 license match.

Hi Lee,
Missatge de Lee Jones <lee.jones@...aro.org> del dia dl., 18 de juny
2018 a les 10:13:
>
> On Mon, 18 Jun 2018, Enric Balletbo Serra wrote:
>
> > Hi Lee,
> > Missatge de Lee Jones <lee.jones@...aro.org> del dia dl., 18 de juny
> > 2018 a les 9:21:
> > >
> > > On Mon, 18 Jun 2018, Lee Jones wrote:
> > >
> > > > On Wed, 06 Jun 2018, Enric Balletbo i Serra wrote:
> > > >
> > > > > The license text is specifying "GPLv2" but the MODULE_LICENSE is set to
> > > > > GPL which means GNU Public License v2 or later. When MODULE_LICENSE and
> > > > > boiler plate does not match, go for boiler plate license.
> > > > >
> > > > > Signed-off-by: Enric Balletbo i Serra <enric.balletbo@...labora.com>
> > > > > ---
> > > > >
> > > > > Changes in v3: None
> > > > > Changes in v2: None
> > > > >
> > > > >  drivers/mfd/cros_ec.c     | 2 +-
> > > > >  drivers/mfd/cros_ec_i2c.c | 2 +-
> > > > >  2 files changed, 2 insertions(+), 2 deletions(-)
> > > >
> > > > Applied, thanks.
> > >
> > > I've just seen Joe's comment.
> > >
> >
> > Did you read my answer [1] to the Joe's email?
> >
> > According to the doc if MODULE_LICENSE is GPL that means  GPL-2.0 or
> > later which to be strict is wrong if your file is GPL-2.0 only. It's
> > right that there are modules in the kernel that have this mismatch but
> > IMHO is wrong, there are also some examples where people fix this, i.e
> > [2]
>
> I did.  Did you read his comment about making these changes wider?
>

Ah ok, that's the reason, so you prefer I do a script to fix this in a
more general way instead of only fix this for cros-ec devices. I'll
do.

Thanks,
 Enric

> --
> Lee Jones [李琼斯]
> Linaro Services Technical Lead
> Linaro.org │ Open source software for ARM SoCs
> Follow Linaro: Facebook | Twitter | Blog

Powered by blists - more mailing lists